Fluent - Time Stepping Method CFL Based problem

I am having issues to set the time stepping of my simulation, i am trying to use a variable time stepping method and i have choose CFL based. my problem is the time step change just when the simulation start, but once it gets the minimum time step size it keep fixed in that even though the max convective courant number is way lower than 0.8.

Thanks for anyone's help!

 

Comments

  • DrAmineDrAmine GermanyForum Coordinator
    edited October 2019
    You are using at least 2 fixed time step sizes. Please check in Fluent transcript if the behaviour is as your settings. You can report plot time step size too.
  • rafa08rafa08 Member
    edited October 2019

    I have checked and the behaviour is as I am setting. My problem is the time step is always going down and it never increase eventhough the courant number is lower than 0.8. am i doing something wrong? in which cases i can used CFL based time stepping method?

    I would expect time step to decrease, but once it stabilizes would hope it increase. why is fluent not updating the time step if the courant number is lower that 0.8?

  • DrAmineDrAmine GermanyForum Coordinator
    edited October 2019
    Please insert the plot of the time step size?
  • rafa08rafa08 Member
    edited October 2019

    I changed the time step to 2e-5, after that it went down to 1e-5 which is the minimum time step size step size

    Thanks! 

Sign In or Register to comment.