An internal solution magnitude limit was exceeded



I am doing non-linear static simulation of a frame in ansys workbench. Since the frame is of uniform thickness i created mid surfaces and the screws are replaced with line elements to reduce the model run time.

In the model i have 4 M4 screws and 4 M3.2 screws, so i have defined bolt pre-tension of 3900N and 2500N respectively.

Line elements are connected to the edges of holes in the frame using bonded contacts. Between the two frame surfaces frictional contact was defined.

Here i have 2 load steps: first with screw pre-tension and second with a remote force of 15KN.

Boundary conditions are:  The hole in the frame was fixed and a remote force of 15KN was applied on the  edges shown.

During the pre-tension load step i encountered the following error.

I know that the reason for such errors are ill constrained model. But as per my knowledge the model is quite well constrained. On internet i found that if we constrain rotational degrees of freedom in z-direction for beams this error would go away. I did it but no luck.

I agree that such a high force of 15KN applied over a small surface is not acceptable, but atleast it should not show any error for pre-tension loads.


Thank you so much for your help.



  • peteroznewmanpeteroznewman Member
    edited November 2019

    The first mistake I have found is the Contact Shell face is wrong. It says Bottom but should be Top.

    I don't know if there are more mistakes, but that would cause the problem described.

  • edited November 2019

    Hi Mr. Peteroznewman,

    Thank you so much for your quick reply. On my computer it is showing the right surface as the contact surface.

    If i supress pre-tension loads, the simulation is running without any errors but the forces are not converging. From your other posts i've learnt that NEQIT command or increasing intitial substeps might erradicate the convergence problem. But i am getting the errors at very first load step (pre-tension load step).

    At first i thought i gave high pre-tension value. But, the same errors are popping up even if i change the pretension value to 1N.

    In the model i have choosen edge of the hole as taget to define bonded contact between beam and hole. 

    Later i changed to surface as the target face, thinking that singularities could occur if i select the edge. But the problem still persisits.

    I can't figure out where it went wrong.


  • peteroznewmanpeteroznewman Member
    edited November 2019

    In my first post, I opened your model using 2019 R3 so that may be the reason why the contact side changed. Note: that's a bug in the ANSYS software if you get a different model when you open it in a newer version.

    I am opening it now using 19.2 and I can confirm the faces are correct.  The mistake I see now is the Shell Thickness Effect is set to No. It should be set to Yes.

  • edited November 2019

    Dear peteroznewman,


    After setting shell thickness effect to Yes, simulation ran for a while and stopped saying that internal magnitude limit was exceeded.

    So i wrote the command \ncnv,,1e60 for the time being and ran the simulation. Simulation is running after that but as usuall due to high forces convergence wasn't achieved.

    Too high forces of order e+13 are recorded at pretension load step itself. But the maximum preload value is 3900N.

    If i am not wrong the force convergence curve should start from round about 3900N and decrease afterwards.


    Could you please tell where else did i commit the mistake in the model?


    Thanks for your help.

  • peteroznewmanpeteroznewman Member
    edited November 2019

    There are two more edits that will help this model start converging.

    1) Under the Connections folder, insert a Contact Tool. Evaluate Initial Contact Status.  All the Frictional (nonlinear) contracts must be Closed.  If any are Near Open, that makes it very difficult for the solver to converge.  There may only be a tiny gap of 1e-3 mm, but that is a problem.  To resolve that problem, go to that Contact and in the Details window, under the Geometric Modification category is the Interface Treatment. Set that to Adjust to Touch.

    2) Under Analysis Settings, change the Automatic Time Stepping to On, then for Initial Substeps, type 10  (and if that is not working, try 100).

  • edited November 2019

    Hi sir,


    I forgot to add initial contact information in the model i attached here.But in my model i checked the initial contact results already and there was one near open frictional contact which i set to adjust to touch.

    Previously i didn't add the auto time stepping for pre-loads. But now i added 100 initial substeps and 100 minimum substeps and 400maximum substeps.

    But still i am encountering the same error.


  • edited November 2019

    Dear peteroznewman,


    I checked the model many times and tried many ways but still it is not working.

    Did you observe anything wrong in the model ?


    Shouldn't i use midsurfaces and line models together in one simulation ?

  • peteroznewmanpeteroznewman Member
    edited November 2019

    You can use midsurfaces and line bodies together. Nothing wrong with that.

    I went through the 8 bolt pretension loads.  Six of them are fine, two of them: #5 and #6, have something wrong with them. If you suppress those two bolt pretensions, it begins solving.

    To use bolt pretension, there must be at least 3 nodes along the beam. Those two beams have no middle node, there is only one element You must add a Sizing mesh control to those last two beams in Geo4 to have Number of Divisions = 2.  That will force a node into the center of the beam, which the bolt pretension needs in order to work.

  • peteroznewmanpeteroznewman Member
    edited November 2019

    Actually, all the beams in Geo4 have a Sizing mesh control of Number of Divisions = 1.  Change that to 2.

    In the Analysis Settings, you don't need the Minimum Substeps to be 100, try 1.  You do want the Initial Substeps to be 100.

    If this answers your question, mark it with Is Solution, or ask a followup question.

  • peteroznewmanpeteroznewman Member
    edited December 2019

    Is this discussion now Solved? Please click the Is Solution link above to mark it as Solved.

  • edited December 2019

    Hello Mr. peteroznewman,


    Thank you so much for your help.

    I implemented the changes you suggested in my model and the model is running now quite well. 

    But the model is not converging. Is it because a high amount of force (15KN) applied over a small area?

    I thought so and increased the area on which the load is applied. Upon doing so, the simulation ran quite well untill 93% and then stopped. But the result is not same as of the test conducted. So i switched back to small surfaces and gave fine mesh on the edges where the force is applied.

    I tried several time stepping options such as : 

    Initial Substeps 100

    Minimum Substeps 100

    Maximum substeps 800  and 500,500,1500. But the model is still not converged.


    Newton Raphson Residual plots as well showing the area where the force is applied.

    Could you please look into the model attached and suggest me of what should i do further to converge the model.




  • edited December 2019

    Dear Mr. peteroznewman,


    I have gone through the soultion information and found out that one of the element in the area where the load is applied distorted.

    So, i removed the fine mesh in the area of applied load and running the simulation again.

  • peteroznewmanpeteroznewman Member
    edited December 2019

    Attached is the model from this post that solved completely after I edited it.

  • edited December 2019

    Hi Mr. peteroznewman,,


    After i implemented your suggestions, Linear analysis of the model executed without any errors. The file you attached here is as well linear.

    But now i am trying to perform non-linear, wherein the model is not converging unfortunately.

    Could you please consider the latest model i have attached if you we would like to perform non-linear analysis from your end.


    Thank you so much.

  • peteroznewmanpeteroznewman Member
    edited December 2019

    I ran the last model and see the excessive distortion error.

    The Remote Force is insufficient to abstract away the missing part and is causing the problem.

    I tried changing the Behavior of the Remote Force from Deformable to Rigid. That only made it worse.

    The missing part makes contact with the two circular holes and the teeth on the third plate. I think you will need to add a simplified version of that missing part to the model.

  • edited December 2019

    Hi Mr. peteroznewman,


    Thanks for your valuable comments.


    I ll simply the missing part and ll bring it into the simulation. I ll define it as a rigid behaviour, because it is a huge metal block to make it computationally inexpensive.


    After i brought that missing part in should i define frictional contact between that block and the surfaces where the force is applied currently?

    And apply a remote force of 15KN force on this block?

    Can i define the contact between a rigid part and flexible surface?


    Sorry for askign you this, becuase at the moment i don't have Ansys with me to try those.

    Or should i perform explicit dynamics?

    I think in explicit dynamics i can't use line bodies and can't also define bolt pre-tension loads.

    Could you please suggest how could i go further with the simulation.





  • peteroznewmanpeteroznewman Member
    edited December 2019

    You can make the new part rigid and apply the 15 kN to that part.

    You don't have to spend any time simplifying the geometry of the part if you make it rigid. There will only be a surface mesh on the faces that are in contact.

    Use Frictional contact between the rigid part and the holes.

    Don't switch to Explicit Dynamics unless you want to apply 15 MN to the rigid part to tear though the sheet metal part.

  • edited December 2019

    Hi Mr. peteroznewman,

    I ll bring the missing part and ll do the simulation as you suggested.

    But before that, I tried the simulation once again by applying the 15 KN force over a relatively larger area which you can see in the below picture.

    The missing part is as well touching these surfaces during the pulling test.

    Simulation ran very well without any errors untill 94% and afterthat distorsion error popped up and simulation stopped.

    But this is morethan enough, because i could see the stresses and how the model is behaving.

    But in the real test, too much plastic deformation occured near the screw holes (highlighted in blue color) and the part flew off as well.

    But in the simulation the V-M stresses in this region are slightly higherthan the yield limit.

    Is this happening because i replaced the real screws with beams?

    Also bonded contact between the beam elements and holes causing this problem?

    I tried frictional contact here, but contact status is open and solver throwed an error as well.

  • momidormomidor Member
    edited March 21

    Hi Peter, 

    I've got bonded contact problem.  

    "Contact status has experienced an abrupt change.  Check results carefully for possible contact separation."

    and as a result:

    "An internal solution magnitude limit was exceeded. (Node Number 21943, Body Part 15, DOF UY) Please check your Environment for inappropriate load values or insufficient supports.  You may select the offending object and/or geometry via RMB on this warning in the Messages window.  Please see the Troubleshooting section of the Help System for more information."


    What does this contact info tells me ?  How can use this hereunder infor to solve problem ? 

    • contact region 5,
    • penetration 3.17e-13 mm, gap 0
    • geometric penetration 1,57 mm, geometric gap 0,26 mm
    • Resulting pinbal 1,59 mm



  • peteroznewmanpeteroznewman Member
    edited March 21

    Hi momidor,

    Please open a New Discussion for this problem. Bonded contact doesn't usually experience abrupt changes. Do you have any frictional contact?

    Maybe there is an incorrect value for a load, or a material property?

Sign In or Register to comment.