Negative cell volume detected

Hi,

I am using FLUENT dynamic mesh to simulate the oscillation and rotation of an object in a 3D fluid domain. 

The motion of the object is defined the motion of each grid using DEFINE_GRID_MOTION and the motion of the object looks correct.

However, when I try to preview the mesh motion, weird thing happens: The Preview Mesh Motioin works fine without Autosave enabled (the time step size is 1e-4 s). After I enable the Autosave option (same time step size), the preview always fails due to negative cell volume detected after several time steps. 

I have tried smaller time step size of 1e-5 s, which still does not work when the Autosave is enabled.

I am not sure if my dynamic mesh setting is wrong as posted below. 

Any help and suggestions are appreciated. Thank you!

Jianan

Comments

  • RobRob UKForum Coordinator
    edited December 2019

    Negative volume tends to mean the motion is too fast relative to the time step and cell size.  Are you starting from the same point in each case? Autosave shouldn't do anything to the mesh so check what's going on. 

  • edited December 2019

    Hi Rwoolhou,

    Thank you for your suggestion.

    Yes, each case is started from the same point. The weird thing is that the preview mesh motion works fine without Autosave enabled for time step size of 1e-4s. After I enable Autosave, negative volume is detected even when I use a smaller time step 1e-5s. Maybe it is related to the UDF? I defined the grid motion relative to its intial coordinates, which I stored in user-defined memory at the first time step. Do you think that gives the problem?

  • RobRob UKForum Coordinator
    edited December 2019

    The autosave function shouldn't have any effect: it's not linked to anything in the solver.  Not sure about the UDF, I assume you're not changing the solver (serial/parallel) between attempts. Do you read the mesh/case in fresh each time you try the preview?

  • edited December 2019

    Yes, I read the case file in fresh each time before I try the preview. Also, I used the same processes in parallel. I tried serial model for once, but it was way too time consuming considering the totoal elements in my case.

  • RobRob UKForum Coordinator
    edited December 2019

    Not sure then. Please can you ask your supervisor to log a support ticket? Without files I don't think we can resolve this, and we're not permitted to do that under the rules on here. 

  • edited December 2019

    Sure, thank you so much for your time and help!

  • TayyabaTayyaba GermanyMember
    edited December 2019

    Hi

    Can you please check it by using 'linear elastic solid' in methods instead of diffusion. Also by changing the minimum length scale to 4e-6, a little bit higher than you displayed information.Also by clicking the cut cell zone in re meshing and setting re meshing interval as 1.

     

    Regards

    Tayyaba

  • edited December 2019

    Hi Tayyaba,

    Thank you very much for your suggestion. Unfortunately, we still get "Negative cell volume detected." error once the Autosave is enabled, although the mesh quality looks fine at the last time step before it went wrong:

    Updating mesh to time 4.70000e-03 (step = 00047)...

    Dynamic Mesh Statistics:

    Minimum Volume = 6.80282e-18

    Maximum Volume = 1.11165e-10

    Maximum Cell Skew = 9.04230e-01 (cell zone 68)

    Minimum Orthogonal Quality = 9.57702e-02 (cell zone 68)

     

    Maximum Face Skew = 5.40841e-01 (face zone 173)

     

    I doubt it is because I store the initial grid coordinate in UDMI, so that after remeshing it would go wrong. But the same happens after I uncheck "Local Face" and "Region Face" in remeshing method. And I am still confused why the preview mesh motion works when Autosave is not selected.

     

Sign In or Register to comment.