Parameters not imported into Workbench 18.2 from Solidworks/Inventor

Hello,

I am trying to iterate over some dimensions of my CAD model and simulate the effect of some forces on the model thus created in Workbench 18.2.

I was using Solidworks 2016 to generate the CAD of my system (I tried using Inventor 2016 also), and followed the instructions at several sources to be able to use dimensions in Solidworks as parameters in my ANSYS Static Structural block (a list of sources I used has been provided below). But here is a summary of the steps I have followed:
Step 1:
For example, in the image below, I have considered a simple example of a disc whose diameter I want to iterate over. Therefore, in Solidworks, I name that dimension "DS_A", so that the Geometry block in ANSYS can recognize the same as a parameter.

Solidworks modification

Step 2: Next, in Workbench 18.2 I created the following simple Schematic, and specified the following properties for the Geometry properties (including the Parameter options shown in the red box).

Workbench Layout

Step 3: 

Now as per the tutorials and forum instructions I followed, the Geometric Parameters should have been imported successfully into Workbench. However, when I load the Model in the Static Structural block, and click on the Part, I am unable to see "CAD Parameters" in the list of Details loaded for my part. I only see the "Graphics Properties", "Definition", "Material", "Bounding Box", "Properties", and "Statistics" options there, as can be seen below:

CDA Parameters Option Missing

I had followed the following tutorials exactly to get the above results, yet, it seems like I am getting a different output from them:
1. 


2. https://forum.solidworks.com/thread/64546


3. https://forum.solidworks.com/thread/113843


and many others that all seem to suggest the same method of re-naming variables and dimensions in Solidworks/Inventor with the Parameter Key "DS" (specified by ANSYS) included somewhere in the names of the variables/dimensions.

The only difference I saw in the tutorials above was that they were using an older version of ANSYS, that had a checkbox by the Parameters property in the Geometry block properties. In the case of Workbench 18.2, this is a dropdown menu with options of "Independent", "All" and "None". I tried both "Independent" and "All" but with the same negative results.

This may be a very simple query, but I am super-new to this software and I might be missing something very simple. Therefore, any suggestions would be very very helpful!
Thank you!

Comments

  • peteroznewmanpeteroznewman Member
    edited April 2018

    You don't say if you are on an ANSYS Student 18.2 license or on a Research or Teaching or Commercial license.

    The Student license does not include the associative CAD interface to SolidWorks that can be included in a Research or Commercial license. If you are on a Research license, then you can look at the license availability and look for 

    Users of pisolwor:  (Total of 1 license issued;  Total of 0 licenses in use)

    A workaround is to open the SW geometry in SpaceClaim and add the design parameters back onto the geometry in SpaceClaim. Workbench will then be able to send new parametric values of those design parameters to SpaceClaim, which can send new geometry back and let Mechanical Solve the model in a Parametric Set.  You can do the same thing in DesignModeler, but you first export the Parasolid from SW then File, Import External Geometry and then build the design parameters using DesignModeler.

     

  • yashcyashc Member
    edited April 2018

    I am on a Research License. And I am able to import the Geometry from SolidWorks, as well as Inventor successfully, as well as run all the tests I want on a given specific geometry. I am only unable to parametrize the model and import the parameters. (A student license will not even allow me to import the SolidWorks file)

  • peteroznewmanpeteroznewman Member
    edited April 2018

    Here is SolidWorks 2017 with a sketch dimension named [email protected]

    When I import this into Mechanical, I can see the parameters when I click on the Body under Geometry.

    Note that the parameters won't show up until you click to put a P in the box.

    Now they show up in a Parameter Set.

    If this isn't working for you, then you may not have run the CAD Configuration tool during installation. You can do that now. Start, ANSYS 18.2, Utilities, CAD Configuration Manager 18.2.   Click the Solidworks and push the Workbench Associative Interface radio button, then Next.

    Then click the Configure Selected CAD Interfaces button. The text in the window indicating Success will appear. Exit.

    Let me know if this fixes your problem.  Attached zip file has a folder with a SW2017 file and an ANSYS 18.2 project file and folder.

    Regards,
    Peter

  • yashcyashc Member
    edited April 2018

    Yes, I think a crucial step missed in all of the tutorials was the CAD Configuration Tool. Once I run this, everything worked.

    Thank you very much.

  • Hi,


    I appreciate this is an old thread but I am beginning to look at using Catia V5 parts with Ansys. The intention is to set up parameters of specific design features in the cad model which can then be read and manipulated by Ansys with CAD model updated with any modifications.  However, this thread is the only one I’ve found which mentions the same issue as I’m experiencing whereby in the Ansys workbench I do not get a Basic Geometry Options ‘Parameters’ check box, only the ‘Independent / All / None’ drop down menu.


    The imported Catpart for testing is a simple cylinder with a parameter and formula to control the length (which I may or may not actually need). I’ve tried all sorts to try and see this parameter and get the parameter check box in Ansys but no joy.  When expanding the Geometry tree it just makes reference to a Partbody and does not expand further to show ‘with parameters’ and so there is no additional boxes to put the ‘P’ in to promote it. This video was useful but it has the parameters check box visible https://www.youtube.com/watch?v=QMh-kc9mHL4. I’ve also tried using ‘DS’ as a prefix and suffix to the parameter name. 


    The CAD Configuration Manager has the Catia V5 ‘Reader (CAD installation not required)’ selected but not the ‘CADNexus/CAPRI CAE Gateway’, perhaps this is the issue and I need this catia plugin?   And I’m using 2019 R3 on an academic research licence. 


    Also, I’m assuming to use DesignModeler rather than Spaceclaim for this exercise?


    Thanks in advance for your assistance with this.

  • @DBond

    Any of the CAD "Reader" plugins are not associative. You need an associative plugin.

  • Thanks for your response.

    From your reply I believe I need to get this CADNexus CAPRI CAE Gateway installed?


  • @DBond

    Yes, I expect this will give you the associative interface.

Sign In or Register to comment.