Motion setup terminals in Ansys Maxwell-Simplorer/cosimulation

chandus127chandus127 CharlotteMember

Hello,

I have been analyzing a co-simulation setup, which has a motor imported from Maxwell 2D into Simplorer. The motor is a four phase one, but imported version shows five terminals, all of them having in and out pins. I am confused with pair of terminals for motion setup. I have few questions on this,

1. What are those pair of terminals named as motion setup1, shown in image.

2. If it is for mechanical load setup! May I know how to connect them without resulting in error.

3. It is taking too much time to run the model When incoming end is grounded and outgoing end is loaded. Is there a way to speed up the simulation?

Comments

  • GayaniDeSGayaniDeS Member
    edited March 1

    Hello, 

    I have been trying to import 3 phase motor to the Simplorer. 

     
    Did you find what are those pairs of terminals named as motion setup?

    Thank you 

  • chandus127chandus127 CharlotteMember
    edited March 2

     

    Yes, I came to know one has to be connected to set speed and the other terminal has to be for the mechanical load. The mechanical load might include torque "F_ROTB" and mass "MASS_ROTB" and speed "V_ROT". If you reverse the speed and mechanical load connections motor will rotate in the opposite direction. 

    However, the induced voltages across windings are not balanced and showing DC offset as well, the torque also fluctuating and average torque is showing as zero. 

     

    Note:

    I have excited the imported model from maxwell with AC current sources to see it's functioning and then will proceed to build controller. 

    The maxwell design or FEA of machine has shown promising results but things have changed when I imported into simplorer with external excitation. 

    I really appreciate if anyone can suggest inputs on the same!

     

    Thanks

     

  • GayaniDeSGayaniDeS Member
    edited March 8

    Thank you for your reply.

    Did you encounter any problem like this  "[Sim2000] Error - FEA1: ERROR - could not find a transient operating point before launching Maxwell >> Calculate at t=0.0005" when doing your cosimulation? 

    I did try changing the time steps.The required time step was very small which took ages to solve. Do you have any idea about this one? 

    I would be glad to hear your response.

    Thank you 

  • chandus127chandus127 CharlotteMember
    edited March 10

    I got the similar error. I tried different time settings. External Circuit Simulation TimeMotor Simulation Time

  • GayaniDeSGayaniDeS Member
    edited March 10

    Thank you for your kind reply. 

    Were you able to resolve that error using these settings? 


    What is the value you used as frequency?

    I tried changing the time settings, but I got the same error. 

    Kind Regards
    Gayani 

  • chandus127chandus127 CharlotteMember
    edited March 10

    Try stop time as 0.0015 and time step as 3.75e-05

  • GayaniDeSGayaniDeS Member
    edited March 10

    I tried that value. Still the error is same. 

    I am building a Field Oriented Control of a Motor. 

    I have a doubt about how Maxwell takes its first current values at the start, As I am controlling the motor using the outputs obtained from it. 

  • chandus127chandus127 CharlotteMember
    edited March 10

    I have excited the imported FEA model with current sources only. I didn't get any promising results so far though the simulation is running. I can see warnings on the convergence. I am still looking for a way to fix it and will go for the next step of modeling if it works well with the current sources. 

    Give a try by exciting with current sources. Do step by step. 

     

  • chandus127chandus127 CharlotteMember
    edited March 10

    I have excited like this. Let me know if you can come up with a solution. 

  • GayaniDeSGayaniDeS Member
    edited March 10

    I'll try that and let you know if the problem is solved. 

    Thank you for your kind response. 

    Regards


    Gayani

  • GayaniDeSGayaniDeS Member
    edited March 10

    Hi , 

    I am using SVPWM for the inverter. Inverter is fed with a rectifier circuit connected with a capacitor in parallel. 

    It was found when the SVPWM module is connected with the capacitor voltage it gives a error like that (Even though the initial voltage of the capacitor is given). And when SVPWM connected with a separate DC source there is no error. 

    There is a possibility that FEA cannot initiate because it doesn't work untill the capacitor is fully charged.

    Hope this might give you an idea. 

  • chandus127chandus127 CharlotteMember
    edited March 11

    did you try connecting a  resistor in series with the capacitor? 

  • PhaniPhani Member
    edited May 7

    Hai Chandu and Gayani

    Did you solved the above error i too pertaining the same... please help if you solved the error

    I been searching for this error but not find any solution ..... I tried changing step time as well by no change in error....

     

    If you solved this give procedure

     

     

  • TeddyTeddy Member
    edited June 1
    Hello Gayani & chandu
    Im also working on 3phase motor control , using FOC method.
    I also encountered the same problem when i use the outputs
    Did you solve your problem?
    Please contact me on [email protected]
  • what are the probable reasons for above warning? Is it affect the results?

Sign In or Register to comment.