Fluent solver slows down with time

Hello ANSYS community,

I've a problem with my fluent solver slowing down with an increasing number of iterations. I'm simulating a transient case of a vertical-axis-wind-turbine on my home computer, which has a Intel Xeon E3-1231 and 16gb RAM and ANSYS 19.1 (free student version) installed on a hard drive.

While this setup is probalby not ideal, the simulation starts fast with multiple iterations solved per second, but with increasing number of iterations the simulation then slows down. Last time I checked (around 10000 iterations in total), one iteration took up to 10 seconds to solve. My best guess is an issue with the memory (maybe?) but the task-manager actually shows that plenty of RAM should be available.

A work-around is stopping the simulation halfway through and restarting ANSYS, then it runs fast again. Sadly this is pretty time-consuming since FLUENT is, once the iterations slowed down, very "sensitive" to button-pressing i.e. freezes for a few seconds/responds slowly to commands. I hope someone has a fix for my (sometimes) lazy Fluent

 

Regards Jan 

Comments

  • RobRob UKForum Coordinator
    edited February 10

    Are you writing animations? I'd also look at updating to 2019R3 or 2020R1 (should be available fairly soon as commercial release was last month). 

  • JanMJanM Member
    edited February 10

     Hi rwoolhou,

    currently I'm not writing any animations, that was actually one of my first steps too speed things up. I'm not even plotting any graphics/xy-plots or such, FLUENT only writes 3 files with moments and forces. An additional information, which might be important but I forgot in my inital post: I'm using the parallel solver on 8 cpus.

    (PS: Since the computers at my university also still use 19.1, I have to keep the older version for now, too keep all data compatible)

    Regards Jan 

  • RobRob UKForum Coordinator
    edited February 10

    How are you using 8core parallel? Should be capped at 4 for Student. 

  • JanMJanM Member
    edited February 10

    Oh really? Didn't know that; as my cpu offers 8 cores I just selected "8" as FLUENT started, but judging the workload of the cores (according to the task manager) it actually uses all of them (also I didn't get an error as far as I can remember).

    Nevertheless, since I'm running out of time a bit (self-inflicted, but that's another story ), I'm also using my old PC (AMD Phenom II X4 955 + 8gb RAM) and my laptop (Ryzen 5 2500u + 8gb RAM) to get some work done. They only have 4 cores anyways, so I'm using the parallel solver on 4 cores there, but I face the same problems with increasing number of iterations (the hardware is less potent for sure, but they also start rather fast and slow down with time).

     

    Regards Jan 

  • RobRob UKForum Coordinator
    edited February 10

    Odd, I'll flag it this side.  

    Sliding mesh can cause a memory leak, typically Fluent's trying to track where everything is, but shouldn't cause anything to freeze. Files shouldn't slow anything up, but check where they're being saved in case you're tight on disc space. 

    To confirm, it's iteration time you're monitoring and not time step?

  • JanMJanM Member
    edited February 10

    Exactly, I'm monitoring the iteraion time which increases with increasing number of total iterations done; so to speak "the simulation slows down"

    (my calculation is indeed a sliding mesh with a fixed time step and a maximum of 20  iterations per time step, if convergence isn't reached)

  • RobRob UKForum Coordinator
    edited February 10

    Not sure, I've not seen this reported on support so can't compare with other cases. 

    We know restarting works. Try re-partitioning too, read up on how message passing works (at a high level) in case that's a factor too. 

  • HI ,

    I am using 19.2 (Research license) from school , I created the geometry, meshed it , used fluent to do set up my case ,but, every single click , it shows the application is loading, and it is very slow .

    I appreciate your help




  • RobRob UKForum Coordinator
    edited September 23

    If it's panels that are taking a lot of time check the graphics drivers and also RAM

    Just noticed your other thread. Are you running remote via VPN?

Sign In or Register to comment.