Batch mode error

Hello,

In my thesis I use Ansys for make the structural part of the reliability analysis and i would like to run ansys in batch mode by an other  program (Numpress). I was made the external call with the program, but I don't get results at the end of the FORM analysis, therefore I'm starting to debugging and want to run my Ansys code from the MS-DOS command line in batch mode, but I have some trouble to run it.

I used the following inputs for running ansys:
C:\Users\mycomputer > d:\BME\MSc-Diplomamunka_Calculations\Beam_example\ANSYS195.exe -b -i Beam_example_input_calc-file.txt -o Beam_example_output_calc-file.txt


I got the following message:

application called MPI_Abort(MPI_COMM_WORLD, 100) - process 0

[[email protected]] ..\hydra\utils\sock\sock.c (420): write error (Unknown error)

send of 28 bytes failed.

Can anyone help me with this problem?

Thank you in advance.

Regards,
Zoltan

Comments

  • RobRob UKForum Coordinator
    edited April 3

    MPI tends to be parallel data transfer, will it run in serial?

  • Totyaaa05Totyaaa05 Member
    edited April 5

    Hey,

    Yes, it will run in serial, because i run just the ansys without the reliability program.
    Did you mean that?
    Please let me know, if I misunderstood.

  • RobRob UKForum Coordinator
    edited April 16

    Not sure. If you run across one rather than multiple cores does it work? 

  • Totyaaa05Totyaaa05 Member
    edited April 30

    Thanks for your suggestion. I have tried it with using 1 thread and didn't get this error message.

     

    BUT

     

    When I run it, I see the Ansys start, but the process is very quick. As I see, the ansys start running, but doesn't solve my analysis. (my output file will not overwrite)

     

    Do you know, how and where can I check, why my script is not running from windows command line?

     Do You have any suggestion?

    [ In spite of that, if I ran my code from the Launcher in batch mode, everything is working well.]

  • Totyaaa05Totyaaa05 Member
    edited May 3

    Hi,

    I got error message in my output file, which was the following:

     *** ERROR ***

     Another ANSYS job with the same job name (file) is already running in this

     directory or the file.lock file has not been deleted from an abnormally

     terminated ANSYS run.  To disable this check, set the ANSYS_LOCK environment

     

     variable to OFF.

     

    I found solution for this problem, if I write the following in the command line, the calculation works good:

    SET ANS_CONSEC=YES

    SET ANSYS_LOCK=OFF

    SET KMP_STACKSIZE=2048k

     

    Because I want to run Ansys with another program, I don't have opportunity to write the above commands in the command line.
    Could I set up these, if I write the correct commands in my input file?

     

Sign In or Register to comment.