ANSYS MAPDL 2020 R1 will not open

Freshly installed ANSYS 2020R1 and when launching Mechanical APDL I get a dll error SR Description: Freshly installed ANSYS 2020R1 and when launching Mechanical APDL i am getting an error "The procedure entry point pow2o3 could not be located in the dynamic link library c:\program files\ansys inc\v201\ansys\bin\winx64\cadoe_core.dll

I installed on another computer and was able to replicate the exact error.  The first computer we did the install on is Windows 10 1909 build.

The second computer is windows 10 1903 build.  The Windows 10 1903 build previously had Ansys 2019 R1 installed and MAPDL worked fine.

 

We uninstalled and reinstalled. removed the cadoe_core.dll file to see if it would recreate at next launch but that just caused a file not found error so we put the file back.   We need help with this issue.

 

Thanks

Tom

Comments

  • tcouperttcoupert Member
    edited April 17

    I should mention that in both windows systems Ansys 2019 R1 was installed previously.  On the first system we did an in place install without uninstalling 2019.  For the second computer we did clean uninstall of Ansys 2019 using the uninstaller found in the program files folder for the application prior to installing Ansys 2020.    Both result with the same issue.

  • mmadoremmadore Forum Coordinator
    edited April 17

    As previously requested, please add the output of the following command from CMD Prompt

    dir /s "C:\*cadoe_core*"

  • tcouperttcoupert Member
    edited April 17

     

     Directory of C:\Program Files\ANSYS Inc\v201\ansys\bin\winx64

     

    12/03/2019  04:18 PM        36,778,480 cadoe_core.dll

                   1 File(s)     36,778,480 bytes

     

     Directory of C:\Program Files\ANSYS Inc\v201\ansys\custom\lib\winx64

     

    12/03/2019  03:12 PM         3,385,654 cadoe_core.lib

                   1 File(s)      3,385,654 bytes

     

  • tcouperttcoupert Member
    edited April 17

    Please let me know what to do next.  

    Thanks

    Tom

  • tcouperttcoupert Member
    edited April 17

    Here is the path for system env in case you need that next

     

    PATH=C:\Program Files\Rockwell Software\RSCommon;C:\Program Files (x86)\Common Files\Oracle\Java\javapath;C:\ProgramData\Oracle\Java\javapath;C:\ProgramData\Anaconda3;C:\ProgramData\Anaconda3\Library\mingw-w64\bin;C:\ProgramData\Anaconda3\Library\usr\bin;C:\ProgramData\Anaconda3\Library\bin;C:\ProgramData\Anaconda3\Scripts;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\WINDOWS\System32\OpenSSH\;C:\WINDOWS\CCM;C:\WINDOWS\CCM;C:\Program Files (x86)\Common Files\AspenTech Shared\;C:\Program Files\Common Files\AspenTech Shared\;C:\Program Files\Microsoft SQL Server\120\Tools\Binn\;C:\Program Files\Common Files\Autodesk Shared\;C:\Program Files\Hexagon\ERDAS IMAGINE 2016\;C:\Program Files\MATLAB\R2019a\runtime\win64;C:\Program Files\MATLAB\R2019a\bin;C:\Program Files (x86)\National Instruments\Shared\LabVIEW CLI;C:\Program Files\PuTTY\;C:\Program Files\Microsoft SQL Server\130\Tools\Binn\;C:\WINDOWS\CCM;C:\WINDOWS\CCM;C:\Program Files (x86)\Bitvise SSH Client;C:\Program Files\Microsoft SQL Server\Client SDK\ODBC\110\Tools\Binn\;C:\Users\Administrator\AppData\Local\Microsoft\WindowsApps;AspenTech\Aspen Hydraulics

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator
    edited April 18

    Yes, it's very likely that this path causes the issue.

    You can do a simple test with the following commands in CMD Prompt first

    set PATH=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem

    "C:\Program Files\ANSYS Inc\v201\ANSYS\bin\winx64\launcher.exe"

    If this works, then the issue is with your Path, you can try reordering it so that those Windows systems file paths (the ones in my command above) are at the front.

    Thanks,

    Win

     

  • tcouperttcoupert Member
    edited April 18

    tried your solution and I still have the same result.  I attached a screenshot.  ANsys 2019 on the same system does not have this issue.  All other applications seem to run OK.  APDL is the only one affected so far from what I can tell.

  • tcouperttcoupert Member
    edited April 20

    I uninstalled 2020R1 and reinstalled 2019R3.  APDL works just fine.  Uninstalled 2019R3 and installed 2020R1 on same system and APDL does not work.  I get that error message.  I have professors on campus that are pushing for the 2020 version but I cannot give them a non functioning version.  Is there a way we can escalate this support issue?

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator
    edited April 23

    Not sure what can cause this.

    Can you post the output of set command ?

    Is there any installation error (install.err under C:\Program Files\ANSYS Inc) ?

    Also, try manually install all prerequisites under C:\Program Files\ANSYS Inc\v201\prereq\   except those with mpi, opencl in the name. Make sure they are all successful.

    You can ask your ANSYS Support Coordinator to reach out to your ANSYS Account Manager and see if this can be escalated.

    Thanks,

    Win

     

  • tcouperttcoupert Member
    edited June 24

    No install.err  and installed all prereqs manually without any errors.  I see that another user has my exact issue  https://studentcommunity.ansys.com/thread/error-when-lunching-mechanical-apdl/?reply=1bf81cfa-534f-43f3-9e4d-abce0155ef74#createpost  

    I replied to that as well.  I found that Aspen V11 by AspenTech is what is causing my issue.  The error occurs regardless of installation order.  Installed ansys after aspen and aspen after ansys to get the same result.  Fluent also has exact pow2o3 error.  different path though.

    The procedure entry point pow2o3f could not be located in the dynamic link library c:\progra~1\ansys inc\v201\fluent\fluent20.1.0\win64\3d_host\fl2010.exe   

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator
    edited June 24

    Thanks. Let's continue on here so we don't hijack the thread from the original poster of that thread.

     

    it's likely that your other application puts some of the libraries listed below in Windows systems files (e.g., C:\Windows\systems32\ ) , which makes it affects ANSYS and any applications on the machine that happens to use the same libraries.

     

    If you check your C:\Windows\systems32\ , you probably have one or some of the following dll's in there

    libchkp.dll

    libgfxoffload.dll

    libicaf.dll

    libifcoremd.dll

    libifcoremdd.dll

    libifcorert.dll

    libifcorertd.dll

    libifportmd.dll

    libioffload_host.dll

    libiomp5md.dll

    libiompstubs5md.dll

    libirngmd.dll

    libmmd.dll

    libmmdd.dll

    libmpx.dll

    liboffload.dll

    Normally, software should not put files in here as it affects the entire systems. You may have to work with the support of the other application to see a way to not put the dll's in there.

  • tcouperttcoupert Member
    edited June 29

    I have every single file that you listed in the windows\system32 folder.  Are these ANSYS files?

    I have ANSYS 2019R3 installed side by side with ANSYS 2020R1.  Those files are there and ANSYS 2019 works just fine but not 2020.

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator
    edited June 30

    These are Intel Compiler dynamic link libraries. Any software that needs this will use these files.

    The problem is that, these files are not supposed to be put here because it affects ALL software on the machine. This is because your Path environment variable always has the C:\Windows\systems32 in its value , which means all software will look for the libraries at this place first before it's looking at the ones from its directory.

    It could be that the version of these dll's are compatible (or may be same) as what ANSYS 2019 is using. This however doesn't mean it would be compatible with other ANSYS versions.

    You will have to find which software put these in there. Or if you just want to try, rename these files to something else and see if there is a software not functioning correctly. 

    Until these files are gone from Windows systems files, ANSYS 2020 R1 will not work. 

    Or if you want , you can use those corresponding .dll that comes with 2020 R1 and replace those in C:\Windows\systems32 but again, this doesn't guarantee if the other software will still function with the newer libraries.

     

  • Did you manage to find a way to get Ansys and Aspen to coexist?

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    As discussed earlier, please contact Aspen and see if there is a way for their installation to not put these Intel Compiler dynamic link libraries under Windows system files

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    Nice ! Thank you for sharing your resolution !

  • I've just signed on here specifically to thank you all for your help. I was having the same issue with 2020R2 (and 2020R1) and with the mechanics solver not starting on various machines. These were being used for teaching in a lab and it was crucial to get this working.

    These machines had AspenTech installed as well.

    The batch file from adblunt worked perfectly! I couldn't ask for more.


    I was also getting a .dll error with Fluent, specifically:

    The procedure entry point pow2o3 could not be located in the dynamic link library C:\PROGRA~1\ANSYSI~1\v202\fluent\fluent20.2.0\win64\3ddp_host\fl2020.exe.

    I received a fix from ANSYS about moving files around which sorted that issue but your fix may sort this out too and is more fundamental.

    I can get some sleep now.

    Andrew

Sign In or Register to comment.