ANSYS Student 2019 R3: No Modules in Workbench

I recently downloaded and installed ANSYS Student Edition 2019 R3. When I try to use Workbench, I can't see any modules. I've tried:

  • Uninstalling and Reinstalling while, clearing registry keys and AppData/Local and /Roaming
  • Checking out the license file, which returns successfully
  • Turning my antivirus off
  • Resetting the workspace and window layout in Workbench
  • Resetting the environment variables

I've looked around, and none of the solutions in other threads have worked for me.

Comments

  • kkanadekkanade Forum Coordinator
    edited May 18

    Please post the questions in appropriate category. Moving this question to other category to get better response. 

    moving to installation. 

    please use latest 2020R1. 

     

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator
    edited May 18

    Please post the output of the checkout command

    From Workbench -> Tools -> License Preferences, then post the screenshot of the list.

    Also, post the output of 'set' command

  • ThelemkoThelemko Member
    edited May 19

    Screenshots of both commands and license preferences in Workbench are below.

    Thank you for your help

    Edit: Reposting pictures for resolution

    License Preferences

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator
    edited May 19

    Remove the environment variable

    ANSYSLI_ELASTIC=1

    Then, try launching Workbench again.

  • ThelemkoThelemko Member
    edited May 19

    Still no luck, the workbench showed no modules.

    I removed the variable with the command "set ANSYSLI_ELASTIC=" and re-ran workbench. Result is posted below:

    I checked afterward and the variable was reset to ANSYSLI_ELASTIC=1

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator
    edited May 19

    The command

    set ANSYSLI_ELASTIC=

    is not permanent. It's only for that particular CMD Prompt session. This is normally done solely for a temporary test. So, if you want to just test it, you need to run the above command, followed by the command to start Workbench like

    "%AWP_ROOT195%\Framework\bin\Win64\runwb2.exe"

     

    But if you want it to be permanent, you have to remove it with a correct way using Windows built-in tool. You can search online on how to do add/modify/remove an environment variable.

     

  • ThelemkoThelemko Member
    edited May 19

    Using a permanent method worked to fix WorkBench, and now all modules are displayed. I tested SpaceClaim to ensure everything worked, and it seems to work so far.

    For posterity's sake, I was able to edit my environmental variables by going to "Advanced System Settings", from which I was able to select "Environmental Variables" and delete the above variable from the user variables.

    Thank you for your help.

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator
    edited May 20

    Good to hear ! Thanks for the details.

    Please mark this thread as 'Is Solution' so we know it's been addressed

  • hidalgoatomashidalgoatomas Member
    edited June 7

    Hi, I have the same problem, so when I try this:

    From Workbench -> Tools -> License Preferences, then post the screenshot of the list.

    image

    " alt="">

    I have 2019 R2 version.

    Thanks for you help.
  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator
    edited June 8

    Check the content of your 'student.lic' file in that error message to see if it has expired. If so, you will have to renew the license according to the steps here

    https://studentcommunity.ansys.com/thread/how-can-i-renew-ansys-student-version-license/

  • i have problem in Ansys 2020, r2 version. let me know how to fix it please.


  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    Do you have an install.err file under C:\Program Files\ANSYS Inc\ANSYS Student

    Try this in CMD Prompt

    "%awp_root202%\..\Shared Files\Licensing\winx64\ansysli_util" -checkout ANS_DM

    does it show "OUT" ?

    You can also try this command in CMD Prompt

    move "%appdata%\ansys" "%appdata%\ansys.old"


    If none helps, try removing the environment variable ANSYSLI_LCP from your Windows

Sign In or Register to comment.