Issue with license for student version

Good morning,

I had the R19.2 working on my PC and I decided to upgrade to the R20.1 version. I uninstalled the software and cleared also the AppData folder, then I installed the new version. When I try to run the Mechanical APCL Product Launcher an error appears saying "No Licensed Products Found".

If I open the Users License Preferences, no license are shown in the top part, for none of the category.

If I search in the Shared Files, the file student.lic is present and it contains the data required.

Can somebody please help me to solve this issue? I already restarted the PC after the installation.

Comments

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator
    edited May 19

    Check your Windows environment variables to see if any of these exist

    ANSYSLI_ELASTIC

    ANSYSLI_LCP

    If so, delete them.

  • LoryMontagnaLoryMontagna Member
    edited May 19

    It worked,thanks.

    The only thing that is different from before is that in Workbench there are only few options, even if in the toolbox customization there are a lot more options selected.

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator
    edited May 19

    That's great !

    Just to clarify, you mean this image is before the issue is resolved or after ? Because this image shows some sign of licensing issue as well.

  • LoryMontagnaLoryMontagna Member
    edited May 19

    Unfortunately, the screenshot has been taken after deleting the two variables in Windows Enviroment. I supposed that everything was fixed because I was able to open the ADPL launcher, but apparently there are still some issues. Therefore, some extra help would be appreciated, thanks.

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator
    edited May 19

    You can try the following command in CMD Prompt (make sure all ANSYS applications are closed first)

    move "%appdata%\ansys" "%appdata%\ansys.old"

    If this doesn't help, from Workbench, click on Tools -> License Preferences, then post screenshot here

    Also, post the output of 'set' command (without quote) from CMD Prompt

     

  • LoryMontagnaLoryMontagna Member
    edited May 19

    Is seems that by moving the directory the Workbench is fixed: all the options appears now, and by opening the License Preferences the licenses are shown.

    Thank you sincerely!

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator
    edited May 20

    Great to hear ! Glad everything is working for you now.

     

  • Hello,

    It seems like I am having the same problem. I have installed the latest student version. So far I have followed every step from this post.

    This is a screenshot from Workbench, Tools -> License Preferences


    and another one with output of command set from CMD Prompt

    Any help would be highly appreciated

Sign In or Register to comment.