STL andbother file type missing

Im re-asking this question since last timebit wasnt answered and then was marked as complete: So I had the 2019 version of Discovery Space Claim and the license expired, so I uninstalled it and downloaded the 2020 version. Every thing seemed to be peachy, but when I opened a spaceclaim file from my earlier version and made a few adjustments. I then went to Save As and saving it in an STL along with a lot of other file types I noticed are not there like the version before. Am I missing something or did I do something wrong when installing? Or maybe an option I have to change inbsome settings...Or is the new version not able to/ did they change the ability to save in STL. I honestly hope Im being dumb.

The object I designed has about 34 faces, pretty simple and not complex. So I dont think that would be the issue. And it sounds like your software has the stl option like my old version used to. But now the list is missing most of the file type options including stl. There are only like 8 or so options on my list in the Save As ( mostly jpg, png, etc.) Nothing useful. I have never had the commercial, just went from 2019 version to the 2020 ? Is there any other reasons why it wouldnt be showing all the file types including stl like it was before?

Save as option only has these file types after upgrade: Spaceclaim files, auto cad dwg, dfx, spaceclaim template, bitmap, gif, jpeg, png, tiff. Nothing useful for a 3D cad software.

Comments

  • peteroznewmanpeteroznewman Posts: 11,486Member
    edited June 2020

    Here is what I have in the Student License of SpaceClaim 2020 R1

    The File Save As command is context sensitive, which means you get a different list depending on what is in your file.

    When you have no geometry in your file, it gives you a short list.

    When you have Solid geometry in your file, it gives you a longer list.

      

    When you have a Facets, then it gives you the STL file format.
    If you have surface or solid geometry, click on the Facets tab, then click on the Convert button to create Facets.

    If this answers your question, please click the Is Solution link below.

  • Element3DElement3D Posts: 7Member
    edited June 2020
    Thanks you, that makes sense, but I was able to Save As stl file in the version before. I didnt change the file at all and the other files I had before I opened up and tried to Save As stl, but all are the same. How did my files turn into files without geometry?
    I should be able to make them solid with facets now with that info, just still kind of new to this software and havent dealt with anything like this before. Thanks for the help!
  • ANSYS_BBuenoANSYS_BBueno Concord, MAPosts: 1Member
    edited June 2020

    Depending on the version, there may have been a separate prompt when you first launch the installer.  This prompt would display one option to install SpaceClaim, and another to install Translators.  If you did not return to the menu and install the translators, you'll see only the short list of file formats when using File > Save As.

    This can be resolved by launching the installer again and clicking Translators when presented with that option.

    A less likely cause is that your PC security blocked something during the installation.  If the procedure above does not resolve the issue, try reinstalling the software using Run as Administrator to launch the installer.

  • DmArcherDmArcher Posts: 4Member


    Hi,

    In my case, I only have the 'SpaceClaim files (*.scdoc)' choice as the image shown below.


    When I install the software, I only have the 'setup.exe' as the installer and there is no such a choice asks about 'Translators'. Once I check the agreement and select the folder for downloading, it immediately start the installation without any other choices. I have run the 'setup.exe' as an administrator and it over-wrote my previous installation, yet no changes happened.

    The next of this page is the installation.

    Nothing else I could do.

    May I know is there a way to manually check the 'Translators'?

    Thank you so much.

This discussion has been closed.