ANSYS Mechanical rescales dimensions of imported geometry

I'm very new to ANSYS, so I apologize if this is a basic question. 

 

I am trying to import an assembly into ANSYS Workbench 2019 R3 from Mimics 3-matic. However, ANSYS keeps rescaling the dimensions of this assembly, making simulation impossible.

 

The file I am opening is a .cdb file with two parts, both volume mesh bodies. I open it using external model with units set to Metric (kg, mm...) because the assembly is only 60 mm long. I run the setup module in External Model to the Model box in Mechanical Model. The dimensions are correct in this model. In addition to the Units for the project being set to the earlier Metric(kg, mm...) scale, the Length Unit field in the Properties of this model are set to mm.

 

I then connect the Model to the Geometry file in a Static Structural system. When I open the Geometry module, I see that the area measurements in Spaceclaim are far too large (though the units are still mm). This can be confirmed when I open the Model section of the Static Structural model. In this module, even though the units are still mm, the dimensions have been all scaled up. For example, the length of the assembly is now 80m when converted instead of the desired value of 80mm. 

 

In the Geometry module, I do nothing except move the assembly to the origin of the global coordinate system and make some Named Selections; nothing to do with resizing the model. Even if I do absolutely nothing in the Geometry section, the same problem arises. As far as I know, I haven't messed with any other settings that could be changing the dimensions like this. This problem is persistent when starting a new project or reimporting the .cdb file.

 

Additionally, if I set the Length Unit field in the first Model in the Mechanical Model to be "m" instead of "mm", I get a similar issue. The assembly is 0.08mm long in the Model in Static Structural instead of 80mm like I wanted, or 80m like it was earlier. If I do it in cm, the final length is 800mm. Similar disrespecancies also appear in Spaceclaim.

 

Does anyone know how to fix this issue with ANSYS automatically resizing a model when I don't want it to? I would really appreciate it, this seems like a silly thing to be stuck on but I can't figure out how to fix it.

 

 

Comments

  • peteroznewmanpeteroznewman Member
    edited July 2020

    I have sometimes seen anomalies like you describe.

    It seems to me that you already found the way to fix this, but overlooked it at the time.

    When you only use meters, the assembly is 0.08 m long, which is exactly 80 mm, the desired outcome!

    Is that true?

     

  • sheamiddletonsheamiddleton Member
    edited July 2020

    No, unfortunately, that was a typo; it was meant to be 0.08mm, not 0.08m. Sorry for the confusion.

  • sheamiddletonsheamiddleton Member
    edited July 2020

    Still trying to figure this out, would really appreciate help.

  • peteroznewmanpeteroznewman Member
    edited July 2020

    What are all the file formats that Mimics 3-matic can export?  Are you saying it exports a cbd file directly?  What other file formats have you tried?

    Are you opening the file in SpaceClaim first?

    Can you put the Mimics 3-matic export file into a zip file and attach it to your reply?  It would have to be < 120 MB.

  • sheamiddletonsheamiddleton Member
    edited July 2020

    The 3-matic types that can export volume meshes are, to my knowledge, .inp (ABAQUS), .cdb (this one is actually just called ANSYS in the export menu but it has the .cdb extension. It does export directly to .cdb. I've also tried .iges and .stl to retroactively fill in the surface meshes, but that didn't work for my geometry), .mphtxt (COMSOL), .msh (FLUENT), .nas(Nastran), .out(Patran), and .fem (FEM). I used .cdb because it seemed to be specially made for ANSYS.

    No, I am not opening the file in SpaceClaim; I'm exporting the assembly/model to ANSYS workbench through the External Model module, then opening it in ANSYS Mechanical in the Mechanical Model module (this is required to set the body materials, or I can't move on), and then opening it in SpaceClaim in the Static Structural module.

    I hope any of this is helpful.

  • peteroznewmanpeteroznewman Member
    edited July 2020

    I would try the .msh (FLUENT) output from 3-matic because that is also an ANSYS file type and you should be able to import that using External Model.

  • Hey, i am also facing the same problem. The route i tried was exporting an STL file from 3-matic and opening it in space claim and then in Mechanical. But it is scaling up my part by almost 10 times and i need to reassign the scaling. Can you tell me how to resolve this?

  • @Rajdeep_11

    Did you select the units on the STL dialog or leave it at Automatic?


  • @peteroznewman whilst exporting from 3-matic I only get an option to change its scaling factor, which i put to 1 with no avail. I think its changing my dimensions from 5 mm to 5 inch and for some reason I cant rescale it back in ANSYS. And I didn't get this STL dialog or maybe i chose a different way. Could you tell me how to rescale it once its in Ansys?

  • peteroznewmanpeteroznewman Member
    edited December 2020

    @Rajdeep_11 In what units is the 3-matic geometry: inches or mm? There are only numbers in an STL file, you can call them inches or you can call them mm as you like, only you know what 5 means. What does 5 mean Rajdeep?

    In SpaceClaim, when you click File Open and set the File Type to STL, you get this dialog. If you set it to Inches, the 5 in the STL file will mean 5 inches. If you set it to mm, the 5 in the STL file will mean 5 mm. It's up to you to know what units were used when writing the STL file and to select those units when reading the STL file.

    You can use the Pull tool to rescale a solid body, but an STL file is not a solid body. First you have to do some work in the Facets tab to Convert to Solid.

  • @peteroznewman Thank you very much! I had the file type set to automatic which set it to inches and now the issue is resolved! I think I saw your video on YouTube and it helped me throughout. I haven't used ANSYS before so I am getting stuck at basic steps so I apologize for that. I was trying to create a geometry from a points file in APDL but it always showed some kind of error even though I re-meshed and smoothened it loads of times in 3 Matic. This path seems to be more effective.

    So once again thanks a lot and have a great day!

Sign In or Register to comment.