Ansys Fluent launched from workbench crashes without warning upon network connection distruption

Hi,

In the event of a momentary internet connection disturbance, I have observed that the Ansys Fluent launched from workbench crashes without warning.

However, when launched standalone it does not crash, works fine, and keeps looking for the license saying disconnected from license server till it reconnects back to the server after a few moments.

Why does this happen? How to prevent this in the workbench environment? In the remote ways of working, we cannot control network disruptions and the crashing of the software makes it very annoying, you have to restart and many times you have to take a step back. I am using Ansys 19.2.


Thank you

Answers

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    These two (WB-Fluent and stand-alone Fluent) should behave the same regarding licensing.

    But in any case, you can try extending timeout to see if that helps.

    In your ansyslmd.ini file under (default location) C:\Program Files\ANSYS Inc\Shared Files\Licensing , add the following lines

    ANSYSLI_FNP_IP_ENV=1

    ANSYSLI_TIMEOUT_FLEXLM=20

    ANSYSLI_FLEXLM_TIMEOUT_ENV=20000000


    Also, if you can update to 2020 R1 or R2, there are new licensing mechanism that can be enabled in these versions, which may be more robust.

  • Thanks for the response. I have included these lines but to no avail. The fluent launched as a part of workbench still error halts. The error log generated only says 'Error .... Abnormal Exit!'.


    Is migration to the latest version the only option?


    Thanks

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    If extending those timeouts don't help, I think you should try the other licensing mechanism that's available in 2020 R#

    But to clarify, before you see this "Error .... Abnormal Exit!" message, does it still say that it lost licensing/connection to license server ?

  • Thanks for your reply. No, it does not give any message at all.


    After the network connection is lost, the fluent runs for about 10 - 15 sec and then it just kills the fluent instance without displaying any warning or error message in the console. The fluent error log files get created which contain only the message - "Error .... Abnormal Exit!".

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    I see. How do you determine when the network connection is lost ?

    You can also check the following file

    %temp%\.ansys\licdebug.FLUENT_SOLVER.192.out

    then look around the time that this issue occurred and see if it complains anything about licensing.

Sign In or Register to comment.