Unable to start the Meshing editor: Object reference not set to an instance of an object.

ArunSJTArunSJT Member
edited August 20 in Ansys Products

Hi,

I'm trying to open Mesh Editor and ending up with the error. Unable to start the Meshing editor: Object reference not set to an instance of an object.

I tried reinstalling the software.

Turning off the Windows security.

Updating my NVIDIA graphics.

Nothing helps me.

Kindly do the needful.


Thankyou,

Arun

Comments

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    Hi Arun,

    Are you connecting to VPN ?

    Also, what ANSYS version you are using ?

    Please provide the output of the following command

    set

    from CMD Prompt.

    Thanks,

    Win

  • Hi Tsiriaks,


    Thank you for the reply.

    1. No, I'm not using VPN
    2. ANSYS version is 2020R2 (Student)

    Output of the command 'set' is

    OS=Windows_NT

    Path=C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Windows\System32\OpenSSH\;C:\Program Files\NVIDIA Corporation\NVIDIA NvDLISR;C:\Program Files\dotnet\;C:\Program Files\Microsoft SQL Server\130\Tools\Binn\;C:\Program Files\Microsoft SQL Server\Client SDK\ODBC\170\Tools\Binn\;C:\Users\91893\AppData\Local\Microsoft\WindowsApps;;C:\Users\91893\AppData\Local\Programs\Microsoft VS Code\bin

    PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC

    PROCESSOR_ARCHITECTURE=AMD64

    PROCESSOR_IDENTIFIER=Intel64 Family 6 Model 126 Stepping 5, GenuineIntel

    PROCESSOR_LEVEL=6

    PROCESSOR_REVISION=7e05

    ProgramData=C:\ProgramData

    ProgramFiles=C:\Program Files

    ProgramFiles(x86)=C:\Program Files (x86)

    ProgramW6432=C:\Program Files

    PROMPT=$P$G

    PSModulePath=C:\Program Files\WindowsPowerShell\Modules;C:\Windows\system32\WindowsPowerShell\v1.0\Modules

    PUBLIC=C:\Users\Public

    P_SCHEMA=C:\Program Files\ANSYS Inc\ANSYS Student\v202\AISOL\CADIntegration\Parasolid\PSchema

    SESSIONNAME=Console

    SystemDrive=C:

    SystemRoot=C:\Windows

    TEMP=C:\Users\91893\AppData\Local\Temp

    TMP=C:\Users\91893\AppData\Local\Temp

    USERDOMAIN=DESKTOP-ARUN

    USERDOMAIN_ROAMINGPROFILE=DESKTOP-ARUN

    USERNAME=91893

    USERPROFILE=C:\Users\91893

    windir=C:\Windows

    Kindly do the necessary.


    Regards

    Arun

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    Hi Arun,

    Thank you for the info. Can you show the first half of the output of 'set' command as well ?

    Are you able to open Design Modeler or it has the same issue ?

    Is there an install.err file under C:\Program Files\ANSYS Inc\ANSYS Student\

    Please launch 'dxdiag' , then click the Display tab and post the screenshot of it here. If you have multiple monitors, post all Display tabs.

    Thank you,

    Win

  • Hi Tsiriaks,


    The full output of the set command.


    C:\Users\91893>set

    ALLUSERSPROFILE=C:\ProgramData

    ANSYS202_DIR=C:\Program Files\ANSYS Inc\ANSYS Student\v202\ANSYS

    ANSYS_SYSDIR=winx64

    ANS_OLD_ATTACH=1

    APPDATA=C:\Users\91893\AppData\Roaming

    AWP_LOCALE202=en-us

    AWP_ROOT202=C:\Program Files\ANSYS Inc\ANSYS Student\v202

    CADOE_LIBDIR202=C:\Program Files\ANSYS Inc\ANSYS Student\v202\CommonFiles\Language\en-us

    CommonProgramFiles=C:\Program Files\Common Files

    CommonProgramFiles(x86)=C:\Program Files (x86)\Common Files

    CommonProgramW6432=C:\Program Files\Common Files

    COMPUTERNAME=DESKTOP-ARUN

    ComSpec=C:\Windows\system32\cmd.exe

    DriverData=C:\Windows\System32\Drivers\DriverData

    HOMEDRIVE=C:

    HOMEPATH=\Users\91893

    ICEMCFD_SYSDIR=win64_amd

    LOCALAPPDATA=C:\Users\91893\AppData\Local

    LOGONSERVER=\\DESKTOP-ARUN

    LSTC_LICENSE=ANSYS

    NUMBER_OF_PROCESSORS=8

    OneDrive=C:\Users\91893\OneDrive

    OneDriveConsumer=C:\Users\91893\OneDrive

    OS=Windows_NT

    Path=C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Windows\System32\OpenSSH\;C:\Program Files\NVIDIA Corporation\NVIDIA NvDLISR;C:\Program Files\dotnet\;C:\Program Files\Microsoft SQL Server\130\Tools\Binn\;C:\Program Files\Microsoft SQL Server\Client SDK\ODBC\170\Tools\Binn\;C:\Users\91893\AppData\Local\Microsoft\WindowsApps;;C:\Users\91893\AppData\Local\Programs\Microsoft VS Code\bin

    PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC

    PROCESSOR_ARCHITECTURE=AMD64

    PROCESSOR_IDENTIFIER=Intel64 Family 6 Model 126 Stepping 5, GenuineIntel

    PROCESSOR_LEVEL=6

    PROCESSOR_REVISION=7e05

    ProgramData=C:\ProgramData

    ProgramFiles=C:\Program Files

    ProgramFiles(x86)=C:\Program Files (x86)

    ProgramW6432=C:\Program Files

    PROMPT=$P$G

    PSModulePath=C:\Program Files\WindowsPowerShell\Modules;C:\Windows\system32\WindowsPowerShell\v1.0\Modules

    PUBLIC=C:\Users\Public

    P_SCHEMA=C:\Program Files\ANSYS Inc\ANSYS Student\v202\AISOL\CADIntegration\Parasolid\PSchema

    SESSIONNAME=Console

    SystemDrive=C:

    SystemRoot=C:\Windows

    TEMP=C:\Users\91893\AppData\Local\Temp

    TMP=C:\Users\91893\AppData\Local\Temp

    USERDOMAIN=DESKTOP-ARUN

    USERDOMAIN_ROAMINGPROFILE=DESKTOP-ARUN

    USERNAME=91893

    USERPROFILE=C:\Users\91893

    windir=C:\Windows


    I can use Design Modeler


    No error files


    'dxdiag' screenshot


  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    Hi Arun,

    Thanks for the info.

    What if you right click on the desktop then launch Nvidia Control Panel >> Manage 3D settings >> set Preferred graphics processor to be "High-performance NVIDIA processor”

    You can also try another setting from Intel graphics control panel. Make sure the power option is set to maximum performance. You can play around with the options under the '3D' setting too.

    Thanks,

    Win

  • Hi Tsiriaks,


    I tried in High-performance NVIDIA processor.

    It is not working.

    Please suggest me some other options.


    Regards

    Arun

  • This was happened after I tried Fluent with Meshing option in Work bench.

    I can use all other tools except meshing.


    Regards

    Arun

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    Hi Arun,

    Ah, I didn't realize this is Fluent meshing. I thought it's ANSYS meshing.

    In that case, if you try stand-alone Fluent with meshing mode selected, does this work ?

    Thanks,

    Win

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    Hi Arun,

    That's actually ANSYS meshing.

    What if you do this

    Under the Component Systems, add the Mesh component. Then draw something in Geometry cell and try opening the Mesh cell

    Do you get the same issue ?

    If so, try the followings

    1. reinstalling prerequisites (you need admin rights for this) by going to folder (default) C:\Program Files\ANSYS Inc\v###\prereq , and manually run all the installers here one-by-one. Make sure they are all successful. You can skip the opencl and MPI related ones. You may need to reboot after this.

    2. Open elevated CMD Prompt (right click on CMD and 'run as administrator' ), then enter the following commands

    regsvr32.exe ole32.dll

    regsvr32.exe atl.dll

    regsvr32.exe oleaut32.dll

    regsvr32.exe scrrun.dll

    regsvr32.exe jscript.dll

    regsvr32.exe vbscript.dll

    move "%appdata%\ansys" "%appdata%\ansys.old"


    Thanks,

    Win

Sign In or Register to comment.