workbench is not launching anymore after the last windows update

Hi, I' m not able anymore to launch workbench 2020 R1.

when I try to do that, the start window appears and the messages on the low withe bar flow untill it shows: " initializing project".

After this it just closes without showing any error message.

this is happening since I did the last windows update but I'm not sure it is the cause, the student licence should last 6 months so it should be still valid.

I hope someone can help me!

Regards,

Lorenzo La Porta

Answers

  • DrAmineDrAmine GermanyForum Coordinator

    Can you check if this helps: open a CMD Prompt and issue move %APPDATA%Ansys %APPDATA%Ansys_old (rename the folder) and try again.

  • Thankyou for answering, this is what I have in my folder:

    C:\Program Files>dir


     Directory di C:\Program Files


    24/08/2020 09:41  <DIR>     .

    24/08/2020 09:41  <DIR>     ..

    24/08/2020 08:45  <DIR>     AMD

    02/04/2020 16:13  <DIR>     ANSYS Inc

    Are you suggesting to rename "ANSYS Inc" ?

    should I copy and past what you wrote? I'm not confident with the prompt, how should I do it?

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator
    edited August 25

    Hi Lorenzo,

    That's not the same directory.

    The %appdata% would lead you to something like C:\Users\<username>\AppData\Roaming

    This is where ANSYS store config files.

    You can just copy-paste the command

    move %APPDATA%\Ansys %APPDATA%\Ansys_old

    hopefully renaming this folder (resetting the config) would help.

    If that doesn't help, try reinstall all prerequisites by going to folder (default) C:\Program Files\ANSYS Inc\v201\prereq , and manually run all the installers here one-by-one. Make sure they are all successful. You can skip the opencl and MPI related ones. You may need to reboot after this.

    Then, run the Product & CAD Configurations GUI with 'run as administrator' -> Configure Products & CAD -> Select all to configure

    Does this help ?

    Thanks,

    Win

  • Hi win,

    I tryed with the first method without succes,

    so I tryed to install what I found in the prereq folder,

    I can't do it with this 3 installer:

    "2017vcredist_x64"

    "2017vcredist_x86"

    "NDP462-KB3151800-x86-x64-AllOS-ENU"

    It says that for some problems I can't install the product, an old version is present and to install it I should do that using the installation app in the prompt.

    no idea how to do that

  • edited August 26

    I also tried to download and install the full workbench again, but stil doesn't work

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    Can you post the screenshots of the error when running these 3 installers ? Please post them inline with text.

    Also, in CMD Prompt window, enter this command

    appwiz.cpl

    this will launch Programs and Features window. Please scroll to see all of the currently installed Microsoft Visual Studio C++ and take screenshot of this. Please make sure it shows the build version number.

  • At the end workbench launched correctly without doing nothing...

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    hmm, that's odd.

    Anyway, I'm glad it's working for you. Thank you for the update.

  • LorenzoMazzeiLorenzoMazzei Florence, ItalyMember
    edited September 22

    Hi, same problem here with 2019R3 since last week. I have tried also to install the current release 2020R2 without any success.


    This is the list of the installed packages. Is there a way to find a log that could describe the problem?



  • LorenzoMazzeiLorenzoMazzei Florence, ItalyMember

    Found it! Through Windows Event Viewer I have realized that the antivirus was blocking it without any notification!

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    Nice find. Thank you for letting us know your issue/resolution.

Sign In or Register to comment.