APDL not Working. Showing me this Error!

I tried reinstalling the program but it doesn't work. I need to resume my coursework on APDL so any help will be appreciated.


Best Answers


  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    Please post the screenshot inline with text as ANSYS employees are not allowed to download attachment.

  • Hello,

    Are you still looking for support on this question? If yes, please post your screenshot in your post (as suggested by @tsiriaks ).

    Thank you!


  • I'm having the same problem.

  • mmadoremmadore Forum Coordinator

    Could you share the value of your PATH environment variable? You can open a Windows command prompt and enter the following command and share the output.

    set PATH

    Thank you

  • Hope this helps Thanks

  • mmadoremmadore Forum Coordinator
    edited October 2020

    Do a Windows search (especially in C:\WINDOWS\system32 , C:\WINDOWS , and C:\WINDOWS\System32\Wbem) for mkl_intel_thread.dll

    Do you see any hit outside the ANSYS directory ? If so, please try renaming it to something else, but please note that this may impact the software that installed this dll. Most applications should have their dlls within their installations to prevent these issues. You may find these files, and if so, rename each by adding .dll.bkup






  • Thanks for your help.

    I've tried that but its just coming up with the same error.

  • mmadoremmadore Forum Coordinator

    Did you find these files in any other locations? Please be sure to search hidden/systems folders and share a screenshot of the search results.



  • Yes I found all three that you mentioned and changed their names.

  • mmadoremmadore Forum Coordinator

    And you only found them in the one directory? The search didn't reveal any other hits? It should result with the ANSYS paths as well as any others that may exist.

  • Ye sorry this these are the full search results

    Thanks again for your help.

  • MangeshANSYSMangeshANSYS Forum Coordinator


    1. First use My Computer - properties - advanced - environment variables - System Variables - Path - edit to make sure the %systemroot% entries aka c:\windows are listed only once. (your screenshot of path lists these folders multiple times. )Try launching ANSYS,
    2. if still issues try adding C:\Program Files\ANSYS Inc\v202\tp\IntelMKL\2020.0.166\winx64 as #1 entry on path even before c:\windows and c:\windows\system32
    3. if still running into issues then use Control Panel - Add Remove Programs to see which intel programs are installed which may have copied mkl*.dll to c:\windows\* paths. make sure you have installation files to install intel MKL files back or it may break other programs or functionality you might have been using for that intel program and try uninstalling it. try launching ANSYS again

    post the outcome here

Sign In or Register to comment.