ANSYS-Fluent Fails to work properly on PC after numerous days of trying.

Hello,

I'm currently a student at Virginia Tech, and with the software package given to us by the university, ANSYS 2020 R1 came with it. For my one course I'm required to download it in order to use Fluent for a large portion of the class. A few days ago, I downloaded it without issue, along with the VPN VT said we needed so the license would work. When I attempted to start up Fluent, not only did it take an excessive time to start-up, at least 6 minutes after selecting a file (A mesh w both 2D and Double Processing enabled), and after a while it tells me fl failed to load. I then tried to read the file from within Fluent, but for some reason it turns the .msh file into a .msh.cas file and gives me another error. I've spent over 3 days attempting to fix this issue, ranging from totally wiping the files off my computer and uninstalling (which one folder couldn't be removed because it was pulling information from the System32 folder of my PC for some reason) then reinstalling (about 5 times at this point), to looking through these forums countless times trying the various solutions to similar problems I was having to no avail.


Originally I downloaded Student 2020R2 before finding out about the 2020R1 my class used that VT gave us, and after the initial failure I uninstalled both variants since I saw you can't go from new to old versions. I thought reinstalling just 2020R1 would work, but it didn't and I'm encountering numerous errors, which I've included in this message. Also, ANSYS doesn't appear as a sole program, along with the licensing software it said I installed during the installation process, and Fluent fails to work when loaded through Workbench. I honestly have no idea what's going on to cause this problem, in addition to the absurdly long load time for Fluent, and I was on a Zoom Call with my professor for over an hour today trying to figure out the issue before he suggested I contact here. This issue is relatively urgent as I need the software fixed, without having to perform a full memory wipe of my PC preferably since that would be disastrous, in order to pass the class, which is one of the few left before I graduate, as I'm also a senior in Mechanical Engineering. The screenshots included show the error messages I've been getting and I'll also include the specs of my PC below.


Any help is greatly appreciated, thank you, and sorry about the epic, I'm exhausted after trying to resolve this issue for over 3 days. I'd also prefer not to have to perform a full-system wipe/Reinstall Windows 10 if possible.


*I've also tried different Paths to see if that was the issue, but they didn't work either. I'm also unable to change Parallel Processing to "0" in the Fluent Launcher menu.


PC Specs:

Dell XPS 15 9560 Signature Edition

Processor: Intel Core i7-7700HQ CPU @ 2.80GHz 2.80GHz

RAM: 16 GB

64-bit OS, x64-based processor

Windows 10 Home OS Build 19041.450

(Everything is up-to-date too)



Answers

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    Just to make sure I understand correctly. Fluent is launched just fine but issue happens when you try to load some files into it, right ?

    Do you have the same issue if you use a stand-alone Fluent ?

    Also, if you can try Student version (either 2020 R1 or 2020 R2) , you can disable VPN and see if it makes a difference.

    Another thing to check is whether you have an install.err file under 'ANSYS Inc' or 'ANSYS Student' folder

  • The Fluent starter works fine when I use the Fluent Shortcut itself, but when I attempt to Fluent through Workbench, I get the "The FLUENT Application Failed to Validate the Connection" Error Message seen above. The starter seems to be fine, but after I click "Start with Selected Files" or don't choose any and still click the start button, Fluent takes a significantly long time to initialize and then displays the error message about fl process unable to be started.


    I'm not entirely sure if what Tech gave me is a Student account or not given it only says 2020 R1, and when I attempted to install 2020 R2 from the free student page on the site here, I got an error message as it completed, which I've included in this post, as it's the intstall.err file in 'ANSYS Student'


    I've tried all these methods with and without the VPN to see if they work but to no avail, Tech keeps telling us that we must use the VPN in order for our license to work, which is 'ansys.software.vt.edu' (License Server Hostname to be specific) according to the software website, but it fails to work regardless and doesn't give me a license error which makes me suspect it's not that.


  • I think my best course of action is to perform a full factory reset and reinstall Windows 10 on my PC at this point unfortunately. Nothing else seems to work

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    If you haven't reformatted yet, you could try the followings to see if there is any luck

    Make sure all ANSYS applications are closed, then

    -run Products & CAD Configurations with 'run as administrator' -> Configure all products

    -open CMD Prompt and enter the following command

    move "%appdata%\ansys" "%appdata%\ansys.old"

    -In Fluent Launcher -> More Options -> Environment tab , add the following

    FLUENT_LAUNCHER_OPTIONS=-driver msw

    You can also try changing around from 'msw' to 'opengl2' or 'opengl'

Sign In or Register to comment.