Trying to run LS-Dyna on ubuntu 2020 system but getting an error

Hello

Trying to run LS-Dyna on ubuntu 2020 system but getting an error:

 *** Error 70004 (OTH+4)

   invalid option on the command line:

 DL_only_DR_run.k

 E r r o r  t e r m i n a t i o n


Please let me know what that error might be. Same input file worked on a different computer just fine.

Thank you much

Leo

Answers

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    Hi Leo,

    On your another computer, is it also running Ubuntu 20.x ? Please provide exact OS version on both computers.

    What is the LS-Dyna version you are using ? And what was the file name of the installation package that you used ?

    Thanks,

    Win

  • ldbuffaloldbuffalo Member
    edited September 4

    Hello,

    I am sorry, correction one computer is at

    NAME="Linux Mint"

    VERSION="19.2 (Tina)"

    The second one is Ubuntu

    Version 20.04.1 LTS (Focal Fossa)

    I used both

    ls-dyna_smp_d_R12_0_0_x64_redhat65_ifort160 and

    ls-dyna_smp_s_r1010_x64_redhat5_ifort160

    Thank you

    Leo

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator
    edited September 4

    Hi Leo,

    I think this is LSTC LS-Dyna. I'm not familiar with this, I will have to ask others to help.

    Can you provide the link where you get these installation packages from ?

    Thanks,

    Win

  • Win,

    It is, Sorry the link is password protected not sure if it is OK to put it in to the open forum like this.

    Thank you very much for trying to help

    Leo

  • I am sorry but we have classes started and at this point I have few students and faculty who are not bale to use this software. ANY !!! help will be appreciated. Thank you

  • Hi Leo,


    The error message tells us that something is wrong on the command line that you use to launch the run. Make sure you specify the input file as follow on the command line:

    i=DL_only_DR_run.k

    Can you send me the complete command line you use to launch the run?


    Thanks.


    Reno.

  • rgbest, Thank you

    I start with ./ls-dyna_smp_s_r1010_x64_redhat5_ifort160 and then input the input file

    and then I get the error

    Thank you again

    Leo

  • Hi Leo,

    I am running on Windows, but the command line on Linux is similar. It should look like this:


    "C:\LS-DYNA\Dev_SMP_Double_Precision\ls-dyna_smp_d_Dev_78944_winx64_ifort170.exe" i=D:\Support\Test\Test.k memory=20m ncpu=-1


    It is better to specify the location of the LS-DYNA solver executable (ls-dyna_smp_s_r1010_x64_redhat5_ifort160.exe) and also the location of the input file (.k file).


    Let me know if it works or not.


    Reno.

  • Reno,


    Thank you will try, but it looks like there us an issue with the licenses. We are using a license server to control licenses and it looks like client system does not talk to the server

    few other systems work just fine with the method that I was using. Will update in few hours when I will try your recommendation, Thanks again for trying to help. much appreciated ...

    Leo

  • Hi Leo,


    Let me know how it goes. If it is a license issue, I can help you with that too.


    Reno.

  • Reno,

    Thank you, it is the license issue, I put the command exactly as you recommend and got the following errors:

    *** License problem ***

     Local license:

     *** Error Bad license keys!

     *** Error 70022 (OTH+22)

       Please contact

        Livermore Software Technology, LLC

        Tel: 844.Go.Ansys (844.462.6797)

        Email: [email protected]

     E r r o r  t e r m i n a t i o n

    ----

    Mind you we do not use local license but a network one.

    Thank you

    Leo

  • Hi Leo,


    You use a network license located on one server correct? If so, this is strange that you are able to run with some client machines and on others you get this error message. This error message tells us that your license file is not valid. You should be getting this error from any client machine. Have you modified the license file? Can you put the original license file back?


    Also, make sure the client machines are pointing towards the license server. In other words, make sure you set the environment variables properly:

    setenv LSTC_­LI­CENSE net­work
    setenv LSTC_­LI­CENSE_­SERV­ER host_­or_­ip
    

    http://www.lstc.com/download#section2


    Let me know how it goes.


    Reno.

Sign In or Register to comment.