FlexNet Licensing: not running

I have installed Ansys16.2 and license manager following instructor, and was trying to get licensing with an academic license in our lab. I got this FlexNet Licensing: not running problem while the other two worked well.

The Error was encountered while stopping the license manager. ansysli_server.exe ansysli_monitor.exe The license manager is running. However, its FlexNet component is not running correctly. To resolve this issue, please manually kill (in the order listed) the ansysli_monitor, ansysli_server, and lmgrd processes, and then start the license manager again through the License Management Center.

However I couldn't find these processes. May I ask for some help

Best Answer

Answers

  • BTW, I have checked the FlexNet Debug Log, it says"

    Server's System Date and Time: Fri Sep 04 2020 03:24:38 Tokyo Standard Time

     3:24:38 (lmgrd) pid 6112

     3:24:38 (lmgrd) SLOG: Summary LOG statistics is enabled.

     3:24:53 (lmgrd) The TCP port number in the license, 1055, is already in use.

     3:24:53 (lmgrd) Possible causes:

     3:24:53 (lmgrd)   1) The license server manager (lmgrd) is already running for this license.

     3:24:53 (lmgrd)   2) The OS has not "cleared" this port since lmgrd died.

     3:24:53 (lmgrd)   3) Another process is using this port number (unlikely).

     3:24:53 (lmgrd) Solutions:

     3:24:53 (lmgrd)   1) Make sure lmgrd and all vendor daemons for this

     3:24:53 (lmgrd)      license are not running.

     3:24:53 (lmgrd)   2) You may have to wait for the OS to clear this port.

     3:24:53 (lmgrd) Retrying for about 5 more minutes

    ...

     3:28:27 (lmgrd) Failed to open the TCP port number in the license.

  • Thank you so much!

    The problem has been solved!

  • Sorry, the problem has been solved and there comes a new error again that stopped the license manager

    pid 9852

    10:01:54 (lmgrd) SLOG: Summary LOG statistics is enabled.

    10:01:54 (lmgrd) Done rereading

    10:01:54 (lmgrd) FlexNet Licensing (v11.13.0.2 build 162702 x64_n6) started on DESKTOP-7TP3LU6 (IBM PC) (9/4/2020)

    10:01:54 (lmgrd) Copyright (c) 1988-2014 Flexera Software LLC. All Rights Reserved.

    10:01:54 (lmgrd) World Wide Web:  http://www.flexerasoftware.com

    10:01:54 (lmgrd) License file(s): C:\Program Files\ANSYS Inc\Shared Files\Licensing\license_files\ansyslmd.lic

    10:01:54 (lmgrd) lmgrd tcp-port 1055

    10:01:54 (lmgrd) (@[email protected]) ===============================================

    10:01:54 (lmgrd) (@[email protected]) === LMGRD ===

    10:01:54 (lmgrd) (@[email protected]) Start-Date: Fri Sep 04 2020 10:01:54 Tokyo Standard Time

    10:01:54 (lmgrd) (@[email protected]) PID: 9852

    10:01:54 (lmgrd) (@[email protected]) LMGRD Version: v11.13.0.2 build 162702 x64_n6 ( build 162702 (ipv6))

    10:01:54 (lmgrd) (@[email protected])

    10:01:54 (lmgrd) (@lmgr[email protected]) === Network Info ===

    10:01:54 (lmgrd) (@[email protected]) Listening port: 1055

    10:01:54 (lmgrd) (@[email protected])

    10:01:54 (lmgrd) (@[email protected]) === Startup Info ===

    10:01:54 (lmgrd) (@[email protected]) Is LS run as a service: No

    10:01:54 (lmgrd) (@[email protected]) Server Configuration: Single Server

    10:01:54 (lmgrd) (@[email protected]) Command-line options used at LS startup: -c C:\Program Files\ANSYS Inc\Shared Files\Licensing\license_files -l C:\Program Files\ANSYS Inc\Shared Files\Licensing\license.log

    10:01:54 (lmgrd) (@[email protected]) License file(s) used: C:\Program Files\ANSYS Inc\Shared Files\Licensing\license_files\ansyslmd.lic

    10:01:54 (lmgrd) (@[email protected]) ===============================================

    10:01:54 (lmgrd) SLOG: FNPLS-INTERNAL-VL1-1024

    10:01:54 (lmgrd) Starting vendor daemons ...

    10:01:54 (lmgrd) Started ansyslmd (pid 9920)

    10:01:54 (ansyslmd) SLOG: Summary LOG statistics is enabled.

    10:01:54 (ansyslmd) SLOG: FNPLS-INTERNAL-CKPT1

    10:01:54 (ansyslmd) SLOG: VM Status: 0

    10:01:54 (ansyslmd) SLOG: FNPLS-INTERNAL-CKPT2

    10:01:54 (ansyslmd) Invalid license key (inconsistent authentication code)

    10:01:54 (ansyslmd) ==>INCREMENT aa_mcad ansyslmd 2016.0930 permanent 5 215FDD2736C3 \

     VENDOR_STRING=customer:01041419 SUPERSEDE ISSUER=SIEBEL \

     ISSUED=29-sep-2015 START=29-sep-2015 SIGN2="00F7 0D2B 057C \

     897A 8CD7 B123 8F26 1200 8D07 F1F2 A9AE AE23 AB44 245B EA46"

    10:01:54 (ansyslmd) Invalid license key (inconsistent authentication code)

    10:01:54 (ansyslmd) ==>INCREMENT aa_ds ansyslmd 2016.0930 permanent 5 14A18DF1CEAA \

     VENDOR_STRING=customer:01041419 SUPERSEDE ISSUER=SIEBEL \

     ISSUED=29-sep-2015 START=29-sep-2015 SIGN2="00A4 7D8E 416F \

     4485 5328 D610 1312 6F00 3958 D0A1 B96A 45F0 BA68 1E24 32F4"

    10:01:54 (ansyslmd) Invalid license key (inconsistent authentication code)

    10:01:54 (ansyslmd) ==>INCREMENT aa_t_a ansyslmd 2016.0930 permanent 5 4A6F583B44E0 \

     VENDOR_STRING=customer:01041419 SUPERSEDE ISSUER=SIEBEL \

     ISSUED=29-sep-2015 START=29-sep-2015 SIGN2="007E 7A4C EB4D \

     FF48 7AA0 BCAE 2870 F800 84D7 804F 1267 CEF9 7303 5381 6445"

    10:01:54 (ansyslmd) License server system started on DESKTOP-7TP3LU6

    10:01:54 (ansyslmd) No features to serve, exiting

    10:01:54 (ansyslmd) EXITING DUE TO SIGNAL 27 Exit reason 4

    10:01:59 (lmgrd) ansyslmd exited with status 27 (No features to serve)

    10:01:59 (lmgrd) ansyslmd daemon found no features. Please correct

    10:01:59 (lmgrd) license file and re-start daemons.

    10:01:59 (lmgrd)

    10:01:59 (lmgrd) This may be due to the fact that you are using

    10:01:59 (lmgrd) a different license file from the one you expect.

    10:01:59 (lmgrd) Check to make sure that:

    10:01:59 (lmgrd) C:\Program Files\ANSYS Inc\Shared Files\Licensing\license_files\ansyslmd.lic

    10:01:59 (lmgrd) is the license file you want to use.


    Does this mean there are some problems with my license file?

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    Is this license file generated for this machine ? License files are specific to each license server machine it's generated for because it uses the machine information in encryptions.

    Check C:\Program Files\ANSYS Inc\Shared Files\Licensing\license_files\ansyslmd.lic

    and see the first line, it should list like this

    SERVER <hostname> <hostID> 1055

    Then, check your ANSYS License Management Center -> Get System HostID. You must see the hostID in the license file listed here; otherwise, this license file won't work on this machine.

  • Thanks for your information.

    I have checked the hostname and hostID and it is the same in ansyslmd.lic file. The flexnet licensing is still not running.

    PS. Actually it might be a sharing license (I'm not sure), for the license file was given in our lab common files and we were supposed to change the hostname and hostID to our own machines.

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    No, you can't modify the license file manually.

    Check the original license file that is sent by ANSYS rep. That is the only machine the license can be installed on and can be setup as a license server machine. Then, all other machines can just tell the software where the licenses are hosted to pull the licenses via network.

Sign In or Register to comment.