Granta EduPack 2020 licensing question

We have Granta EduPack 2020 (Ansys licensing). Ansys license is installed and working. The ports 1055 and 2325 are open to the clients. Granta seems to install fine, but when we try to run the software, we see ""Your license could not be loaded. Please check your license settings, including license server configuration."

What is seems to be the problem?

Best Answer

Answers

  • mmadoremmadore Forum Coordinator

    Please check your C:\Program Files (x86)\GRANTA EduPack\Shared Files\Licensing\ansyslmd.ini file to ensure it lists the correct server details.

    Example:

    [email protected]

    [email protected]

  • Thanks for the response. This did not help. We have the correct information in the ansyslmd.ini file. Those ports are also open to the client.

    A question: In the license file, hostname is shown as ansys-license (the first line in the license file: SERVER ansys-license DISK_SERIAL_NUM=<hostid> 1055). But ansys-license is not the full domain name. Does it need to be the full domain name? If so, can we change it?

  • mmadoremmadore Forum Coordinator
    edited September 8

    Are the ports open on the SERVER?

    It does not need to be the full domain name, unless the client machines cannot resolve the server as ansys-license. If it can't be resolved by clients, please do revise the hostname in the license to match the FQDN.

  • Thanks again. Yes, the ports are open. We generally do a telnet test from the clients to the server with port numbers (telnet <server_name> <port>). This works.

    I changed the server name to FQDN. The license manager does not want to load the file because it thinks it is the same! How do I remove a previous license and reload a new one? Also, how do we see if the client is contacting the server? None of the license log files seem to show it.

  • mmadoremmadore Forum Coordinator

    You can stop the license manager, edit the file and save it, then restart the license manager. Or you can edit, save to your desktop, delete the existing ansyslmd.lic, then use the ANSYS License Management Center to install the modified file saved to your desktop.

    Please check to see if the Client has the ANSYSLI_ELASTIC or ANSYSLI_LCP environment variables set, if so please try removing them.

  • Thank you again for your help. Unfortunately none of this has helped. The env variables are not set and replacing the license file with FQDN did not help. Do you have any other suggestions? What should we look for on the server when the client is trying to contact the server?

  • Yes, it was the third dynamic port issue and we fixed it by making 1056 static. Thanks! We had come across the same solution via another post on the Ansys forum:


  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    Great ! Thank you for the update. Also thanks for searching past threads.

  • Hello, i'm having the same issue. I've installed Granta EduPack on a test pc. i get the same error"Your license could not be loaded. Please check your license settings, including license server configuration."

    License seems to be running fine on the server. I've even installed Ansys Fluent on the same PC and it seems to work fine.

    Any help would be greatly appreciated. Would like to get Grant working since students have been without for the past few days.


    Thanks

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    Check if your license file has this granta_edupack license feature (the one on the INCREMENT line)

    If so, check the networking just like what discussed here. You need two ports to be open between client and server machines : one is 1055 by default, the other is dynamic default

  • Hello,

    I did check the license file and it does have the increment granta_edupack (INCREMENT granta_edupack ansyslmd 9999.9999 31-aug-2021 50 \)

    As for the networking part, not sure what you mean? my license file looks like this (removed some info)

    SERVER XXXXXXXXXX DISK_SERIAL_NUM=XXXXXXX 1055

    VENDOR ansyslmd

    USE_SERVER


    Why would Ansys CFD be working ok on the same computer?

    Thanks again

  • Hello,


    I managed to get it working. Thanks for your response

Sign In or Register to comment.