Problems with a new flex linux license setup for Ansys

Hey Everyone,


I migrated over to an AWS EC2 instance to serve my Ansys licenses, and I'm having some problems with the setup. The firewall looks fine, and an nmap on the ports I've specified for the license are open and running well. The log files look totally fine, both Ansys license processes also seem to be running fine, and I ran the exact same commands on the old server to get this running. I'm running v202 for the license manager with a freshly generated license.


What should I be doing to get this issue fixed? Everything seems to look just fine on my end.


Thanks for your help everyone!


Jack Bradley

Computer Systems Administrator

College of Science and Engineering, Idaho State University

Comments

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    Hi Jack,

    Could you describe the issue in details and if applicable, provide screenshots of the issue ?

    If you are getting SSL handhsake error, try setting an environment variable ANSYSLI_LCP=1 on the client machine.

    Thanks,

    Win

  • Hey Win,


    Sure thing. I've attached a few photos for reference, as well as the log file for the server. The license status looks to be up and running well, but when I try to launch Mechanical APDL for instance, it fails to check out a license.



  • Hello,


    Any advice on this issue would be greatly appreciated!

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    Hi Jack,

    Sorry for the delay. If the license status is good, it means your FlexNet and vendor daemon ports are open.

    However, when ANSYS (Mechanical/Fluent) checks out licenses, it uses another port which is for ANSYS Licensing Interconnect. This port is default to 2325. On the license server, it's used by this process ansysli_server. So, please check if this is up and running and if it's on which port, then you will have to make sure that client is specifying that port and is able to connect to the license server via that port.

    Thanks,

    Win

  • Hey Win,


    That port is open. Where do I specify that in the Ansys client installation?

  • This is the error message I'm getting now. So I think the ANSYSLI process is running okay, but FLexlm isn't? Looks like both ports are open fine.

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator
    edited September 21

    ah ok.

    For this error, it's the delay in network communication, so the ALI timed out.

    You can extend this by appending the following keywords in (default location) C:\Program Files\ANSYS Inc\Shared Files\Licensing\ansyslmd.ini

    ANSYSLI_FNP_IP_ENV=1

    ANSYSLI_TIMEOUT_FLEXLM=10

    ANSYSLI_FLEXLM_TIMEOUT_ENV=10000000

    Please do this on BOTH client and license server machines. If the license server doesn't have this file, you can just create it and add these in the content.

    Let us know if that helps with this error.

    Thanks,

    Win

Sign In or Register to comment.