ANSYS HFSS is not openning

In my computer, HFSS is installed properly. I worked on that one day ago. But now if I want to click HFSS or any HFSS files, they are not opening, not showing any error message also. I double clicked, also right click then open nothing worked. I never faced this problem before.

Tagged:

Answers

  • mmadoremmadore Forum Coordinator

    This could be related to a recent issue, showing in many recent posts on the forum. A recent Windows update, Microsoft update KB4571756, results in one of the Windows functions crashing on startup. Please try setting the environment variable ANSYS_EM_DONOT_PRELOAD_3DDRIVER_DLL=1 to get around the problem.


    For guidance on creating an Environment Variable please refer to this link. You need to create a NEW Variable.

    https://www.computerhope.com/issues/ch000549.htm

    New Variable Name: ANSYS_EM_DONOT_PRELOAD_3DDRIVER_DLL

    New Variable Value: 1

  • Han-yuHan-yu CharlottesvilleMember

    Hi mmadore,

    I also faced the same issue recently, could you guide me through the fixing process?

    I add a new variable to the environment variable as the picture shows below, but I since cannot open the "ANSYS Electronics Desktop" and other applications.

    Thank you

  • mmadoremmadore Forum Coordinator

    You may also try uninstalling update KB4571756.


    To uninstall the Windows update:

    1.      Select the start button or Windows Desktop Search and type update history and select View your Update history.

    2.      On the Settings/View update history dialog window, Select Uninstall Updates.

    3.      On the Installed Updates dialog window, find and select KB4571756, and then click the Uninstall button.

    4.      Restart your Windows device.


    Additionally, you may be able to run the following from an elevated CMD to uninstall the update:

      wusa /uninstall /KB:4571756 /quiet /promptrestart

  • Han-yuHan-yu CharlottesvilleMember

    Hi mmadore,

    Thank you for your advice.

    After I uninstall the Windows Update, the Ansys Electronic Desktop can open.

    Thank you!

  • this is from a new installation of 2020R2 on a machine with the update.



  • mmadoremmadore Forum Coordinator

    @trimbleGU did you try the options from this thread and then reinstall?

  • @mmadore Yes, I added the environment variable before installing. I did not uninstall the update. It seems to run even though it throws that error though.

Sign In or Register to comment.