S-ALE Fails When Using MAT_ALE_INCOMPRESSIBLE

Hi Everyone,

I am trying to do a simple bore in a box simulation where a dam of water is allowed to flow around in side a box, however, the simulation keeps failing with the following error:

 *** Error 40660 (SOL+660)

   The laplacian diagonal term for the element 1

   is zero. It usually occurs when the nodes of this element

   are constrained in all directions

The simulation makes just past the storage allocation lines then the error causes the simulation to fail before a run-time estimate is presented.

I am not exactly sure what this error means as even when I remove any constraints from the model I still get the same error. The .k file is attached but how I defined the materials is as follows:

*MAT_ALE_VACUUM - to model the air, section SOLID, ELFORM = 6

*MAT_ALE_INCOMPRESSIBLE - to model the water, section SOLID, ELFORM = 6

I filled the S-ALE mesh using the *INITIAL_VOLUME_FRACTION_GEOMETRY card.

Does anyone have any idea why this model fails to run?

Cheers!

Answers

  • idoido Member

    Hello PatJoy,

    ELFORM=6 is "single" mat Eulerian. You cannot model 2 ALE mats with it. It is obsolete because to do FSI effectively you need ELFORM=11=multi-mat-ALE (MMALE) formulation where you have both water and air in the the domain. You can fill air into the space overlapped by the LAG "box" or dam perhaps (?). If I may suggest, please review my tutorial before attempting to model with ALE. It typically requires a class to get going. Please find my old tutorial at:

    http://ftp.lstc.com/anonymous/outgoing/ian/aletutorial.tar.gz

Sign In or Register to comment.