Error with workbench SceneGraphChart

I tried to install the ANSYS Student package 19.1 and this SceneGraphChart problem pops up. I saw the post that a guy wrote here in the forum asking for help for the same problem, but the solution given to it did not work for me at all.

An unexpected error has occurred: The following required addins could not be loaded: Ans.SceneGraphChart.SceneGraphAddin. The software will exit. --- System.AggregateException: The following required addins could not be loaded: Ans.SceneGraphChart.SceneGraphAddin. The software will exit. --- System.Exception: SceneGraph.Engine - failed to boot up. at Ans.SceneGraphChart.Engine..ctor(IConfiguration p_config, IErrorHandler p_errorHandler) at Ans.SceneGraphChart.SceneGraphAddin.Load(AddinLoadContext context) at Ansys.Core.Addins.AddinManager.setupAddin(String path, String name, AddinBase addin) at Ansys.Core.Addins.AddinManager.LoadAddin(String name, String path)

I have Windows 10 Pro x64;

I changed my username to one without accent and space;
I tried install both on C and D (Both physical local driver);
I always open with administrator privileges;

I tried everything that tsiriaks say on this post:

https://studentcommunity.ansys.com/thread/ans-scenegraphchart-scenegraphaddin/

But nothing changes. Please, anyone can help me?



Thanks in advance and please ignore some misspelling in my text.

«1

Comments

  • jcalleryjcallery Forum Coordinator
    edited August 2018

    This could also be graphics card related.

    Please update your graphics drivers to the latest version, and verify that the "good" card is enabled as the primary card.

    For instance if you are using a laptop with an intel card and an nvidia card in it, open the nvidia control panel and 3d settings, and verify that "High Performance Graphics Processor" is selected as the primary card and not "auto detect"

    Which graphics card are you running?

    Thank you,

    Jake

  • MoedaVerdeMoedaVerde Member
    edited August 2018

    My video card is a GEFORCE GTX 1060 updated. I wonder, is this problem because the Ryzen 7 processor has no GPU?

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator
    edited August 2018

    Hi MoedaVerde,

    Could you provide screenshots of 'dxdiag' just like user SK_Runek provided in

    https://studentcommunity.ansys.com/thread/ans-scenegraphchart-scenegraphaddin/

    Also, have you tried Jake's suggestions for Lindsay (from the same post above) 

    #####

    Can you try closing all open ansys applications and rename the following directory:

    %APPDATA%\Ansys

    to

    %APPDATA%\Ansys_old

    Then try launching workbench from the shortcut again.

    You may also want to try running ProductConfig:
    Start -> All Programs -> Ansys -> Utilities -> Right Click on Product and Cad Configuration -> Run As administrator

    Then click on Configure Products and Cads and follow the prompts.

    #####

     

    Thank you,

    Win

  • CelioGPCelioGP Member
    edited August 2018

     

    I have the same problem. I have a Nvidia GeForce GTX 745 video card

  • jcalleryjcallery Forum Coordinator
    edited August 2018

    Hi CelioGP,

    Which suggestions from this thread have you tried thus far?

    Additionally, please try the suggestions in this thread:
    https://studentcommunity.ansys.com/thread/ans-scenegraphchart-scenegraphaddin/

    Thank you,
    Jake

  • CelioGPCelioGP Member
    edited August 2018

    Hy JCallery

    I renamed the% appdata% / ansys directory to ansys_old I have already done this: Start -> All Programs -> Ansys -> Utilities -> Right Click on Product and Cad Configuration -> Run As administrator I already updated the driver of my video card. Follow the error and dxdiag photos

    https://drive.google.com/file/d/1iwG-SmdBVltZDXJqv4YR5Eq4uTgArH8H/view?usp=sharing

    https://drive.google.com/file/d/1dV1HsWROVubmdEPmOl6WUp6_CmUfmMio/view?usp=sharing

  • jcalleryjcallery Forum Coordinator
    edited August 2018

    Hi CelioGP,

    Thank you.

    Could you please try changing your language and locale to English and en-us?

    Thank you,
    Jake

  • CelioGPCelioGP Member
    edited August 2018

    Jcallery,

    how do I do that?

     

  • jcalleryjcallery Forum Coordinator
    edited August 2018

    Depending on your version of windows, please try something like the following:
    https://www.wikihow.com/Change-the-Language-in-Windows-7

    Thank you,
    Jake

  • aliberatialiberati Member
    edited August 2018

    Hi all, 

    As a follow-up of these questions, I was having the same issue on my computer with the Ansys Student Pacakge under Windows 10.

    I tried most of the advice you offered :
    - updating my graphics cards drivers - I have a Intel(R) HD Graphics 530 and a NVIDIA GeForce GTX 960M
    - running my Nvidia control panel and setting the "high performance processor" instead of "auto-select"
    - renaming the %appdata%\Ansys to %appdata%\Ansys_old
    - running ProductConfig which seemingly had nothing to change 
    - installing on both my C: (SSD harddrive) then my D: (HDD harddrive)
    - running an existing project to at least open something of the program
    - restarting my computer after each process

    None of these worked.

    The last step I tried was changing my username on Windows. I wanted to change my user folder name that contained accents, but failed to do so - instead I changed the session username to a name without accents (I accessed the Advanced User Accounts panel by looking for "netplwiz" (Windows application), by clicking on my user name, then Properties, then by changing the name, applying the settings and rebooting the computer) : surprisingly enough, this worked actually.

    After rebooting, I could open the Workbench and launch the different processes. 

    Now I am having other issues though as Fluent won't launch with another list of error codes - but I guess it wouldn't be relevant here. At least I have the Workbench now.

    Best of luck to the other reading this who may have issues.

    (EDIT : Issues with Fluent may still be related to the "accent situation" as it searching for files from C:\Users\D?d?\... whereas files are in C:\Users\Dédé...)

    MAJOR EDIT : Apparently, "just changing" the User folder name is impossible and requires creating a new account or reinstalling Windows (https://answers.microsoft.com/en-us/insider/forum/insider_wintp-insider_security-insiderplat_pc/rename-user-account-folder-in-windows-10-preview/88033eca-6b32-47c5-90ac-a5e7af17d094). So I created a new User account (took 5min), made sure I had no accents in the name (called it Ansys) and now it's working like a charm. Hopefully this can solve your issues future readers ! 

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator
    edited August 2018

    Hi aliberati,

    Thank you for sharing your resolution. This would definitely be helpful to others.

    Thank you,

    Win

  • frank2243frank2243 Member
    edited November 2018

    Did anyone have ever found a solution for this problem?

    I have Windows 10 installed on an iMac 5K with the latest AMD drivers.

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator
    edited November 2018

    Hi frank2243,

    See the discussion here

    https://studentcommunity.ansys.com/thread/installation-problem-in-workbench-19-2/

    If this doesn't help, please create a new thread.

    Thanks,

    Win

  • ra9841lura9841lu Member
    edited May 2019

    Yes, that's the solution, I have (or had a minutes ago) the same problem, with that message I tought it was my GPU (GTX 1070 laptop) or the fact that I use a laptop so I need to change from the intel gpu from nvidia one for ANSYS, but no. The problem was that my windows is in Spanish and my user name have spaces and an accent (Raúl...), so I just create a new user account in english and just named Ansys, and worked! thanks, mention that I tried all the other solutions but not worked. I really wonder if you can on the next uptade fix this error please. 

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator
    edited May 2019

    Hi ra9841lu,

    That's great. Thanks for letting us know.

    We've submitted this enhancement request to our development team. Hopefully, this is improved in the near future release.

    Thanks,

    Win

  • edited September 2019

    Hi,

    Ansys electronics desktop is giving error message when i try to open 3d component as" this 3d component is created in future version of this product and cant be open in this" My ansys electromagnetic suite is 19.2 version..kindly help to fix this error

  • RobRob UKForum Coordinator
    edited September 2019

    It means that the model you're trying to open was created in a newer (probably 2019Rx) version of the code. You need to update to the later version to open the model. 

  • edited December 2019

    hello guys, i had the same problem for about 10 days.now, I got over with these problems.

    I would like to say how to I got over this issue "unexpected error the following required addins could not be loaded...etc"

    First of all , this problem arise from using a letter which does not belong in English language.For ex,, ? i ç ,ü,?...etc

    So, first thing that you have to do , press Windows +R  buttons and write "netplwiz" afterthat you will see your account(s). then add new account name with english letters.(You dont need to create with microsoft e-mail and just click local account.)And give it administrations.Before next step ,you had better backup your files because you will delete it,your current account.But it is not big deal to get back your files because you have already downloaded your files. just you might spend your time to find where the files in.It worked on me. now i can use these ansys  apps. I hope it will work on you.Good Luck!

    Emre

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator
    edited December 2019

    Thank you for sharing your resolution Emre

    Win

  • maternmatern Member
    edited February 6

    With the same problem, this method helped solve it. Thanks.

Sign In or Register to comment.