Fluent is freezing out in Unix based cluster

lcmaldonadojlcmaldonadoj Member
edited September 18 in Ansys Products

Hi all:

I am recently having problems using fluent in a Unix based cluster. The problem is the following: I load the modules of ANSYS and start fluent using the GUI interface (I have tried to open it in parallel and serial). Then, I try to read a file by clicking in the tab File->Read. Then, I select the file that I want to open. What happen after that, is that fluent is freeze out. Previously, fluent started to show commands in the console as fluent was reading the files. Now it seems fluent is not doing anything. I have left the program run for hours to see if this was a matter of time but still didn't work.

Another strange thing that is happening to me is that, if a click on File->Read and then just cancel this, again fluent is freezing out and then I cannot do anything else in fluent. No clicks in the GUI or type something in the console.

We have tried several things with the ITaP people in my university and it seems that is only with my account. I have opened some files in my local office computer and it worked, but in the cluster is not working.

Does someone know what is happening?

Best,

Luis Maldonado

Comments

  • RobRob UKForum Coordinator

    If it's unique to your account check for storage space and permissions: you won't be the first person to fill their disc allocation and then not be able to launch anything. Also try the test with a very small model, we want to check the solver will open rather than run anything meaningful so a case with 10 cells is fine for this.

  • Hi Rob:

    I have been working with the ITaP team of my university during these last days. We found out that we could open the .cas and .dat by using the console instead of the GUI. What I mean is that I launch fluent and then I type in fluent's console file/read-case-data/"filename." Also, we found that despite we can open the files using the commands if I try to write the files using the GUI buttons it will freeze out again. So, the solution again is to save the files using fluent's console.

    Another way that we found that worked is to open the files through workbench (runwb2). By using fluent through workbench we don't have any freeze out problem using fluent's GUI.

    We think that this problem could be caused by a corrupt file that is related to the use of fluent's GUI and is linked only with my account. My advisor and colleague don't have this problem (we are using the same cluster). We checked the permissions in general for my account and everything looks in order. I am not sure if we have to check and specific file instead.

    Best,

    Luis Maldonado

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    Hi Luis,

    This could be a graphics issue as well although it's hard to tell why it's specific to your user account.

    For stand-alone Fluent, in Fluent Launcher -> More Options -> Environment , you can try adding the following.

    FLUENT_LAUNCHER_OPTIONS=-driver x11

    see if this makes any difference.


    For Workbench-Fluent, try the following (you can also add the same thing above in this Fluent launcher)

    export LIBGL_ALWAYS_INDIRECT=1

    export LIBGL_ALWAYS_SOFTWARE=1

    export LD_LIBRARY_PATH=<install_dir>/v###/Framework/bin/Linux64/Mesa

    <install_dir>/v###/Framework/bin/Linux64/runwb2 -oglmesa

    Note: You have to replace <install_dir>/v### , with the actual installation path and version number.

  • RobRob UKForum Coordinator

    Did you alter any of the preferences in the standalone Fluent? They're not saved in the same place as the WB side so you could have done something last time you ran Fluent standalone.

  • lcmaldonadojlcmaldonadoj Member
    edited September 25

    Hi tsiriaks:

    Thank you so much for your pieces of advice. I am only having problem with the standalone Fluent. I tried what you suggested me, but the problem still remains.

    Thank you!

  • Hi Rob:

    I haven't changed any preferences (on purpose at least) in the standalone Fluent. What is weird is that this problem started after I closed a case that I was running during the night. As a little explanation, I let run over the night a case using the standalone Fluent (it was working perfectly), then next morning I checked the results, saved the data, and closed Fluent. After that, I tried to open a different case with a different configuration and then is when the problem appears.

    Regarding the preferences, I will check them and see if I can find something.

    Thank you!

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    what if you try changing the working directory to say /tmp ?

  • Hi Tsiriaks:


    I tried what you suggested me and it didn't work.

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator
    edited September 25

    What if you try setting the following environment variable before starting Fluent


    C Shell

    setenv HOOPS_PICTURE x11


    Bourne and Bash Shells

    export HOOPS_PICTURE=x11


    You can also try setting this

    LD_PRELOAD=/usr/lib64/libstdc++.so.6

  • Hi Tsiriaks:


    I tried all the last command and still doesn't work.

  • Hi all:

    I tried different versions of the standalone fluent: 18.2, 2019R3, and 2020R1. Surprisingly, the only version that doesn't freeze out, is 18.2. I don't know if this fact helps to identify why this problem is happening.

    I will start working with Fluent 18.2, but I will continue working with the technology department to figure out what is happening with the other versions

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    When you mentioned others have no issue, do they use exact same node as you ?

    If so, the next step would be to check and compare the output of the following commands


    env

    lspci -vnn | grep VGA -A 12

    glxinfo | grep OpenGL


    between the two user accounts using the same node

  • Hi tsiriaks,

    I checked the output of all the commands that you mentioned before, and between the two accounts everything looks the same.

    I just figured out that I am also having the problem in the Fluent launcher. To make my explanation easier I just uploaded a video in YouTube with the problem (https://youtu.be/DkLSF_PtHME).

    Thank you.

Sign In or Register to comment.