Mesh generation will not complete

I have received this message for multiple tutorials in my college class. The geometry file should not be the problem because I am the only one in my class having this issue. In the shown tutorial I am attempting to change the part material to aluminum alloy, and when I got to refresh and then update the part, I receive the shown message. I am running ANSYS on windows 10 for the first time, I believe the meshing method is automatic.

I have also tried to only generate a mesh for the object and I receive the same error.

Answers

  • gnagappgnagapp Forum Coordinator


    Are you able to mesh any other model? If meshing always fails on your machine with this error message, this could be a reason:

    ANSYS WB has been installed on a machine that has significantly older versions of CAD/CAE applications installed.

    We have seen this error on machines that had ANSYS 19.x (released in 2018) and AutoCAD 2013. This old AutoCAD release and also other older CAD/CAE programs copy their DLL files into C:/Windows/System32. ANSYS can have DLL files with the same names (which are however located in C:/Program Files/Ansys Inc/v19.x) - in such cases it uses the DLLs from the Windows directory instead its own files. Very old DLLs in the C:/Windows/System32 can be incompatible with the recent ANSYS versions, which can cause the unexpected behaviors such as those described above.

    Installing ANSYS on a machine without CAD/CAE applications older more than 3-4 years than the ANSYS release might be a more efficient way to bypass the problem. Rather than Identification of old foreign DLL files in C:/Windows/System32 which can be a challenging task.


    If you are able to mesh other models and just this case is failing, try changing the mesh sizes/method and see if it helps. Use a smaller size and see if helps

  • I am having issues with all models that I have tried to use. The geometry files are Solidworks so I updated my 2019 Solidworks software to the 2020 version, however I am still unable to mesh the model with the 2020 Solidworks installed.

Sign In or Register to comment.