License Manager issues on virtual machine

Dear Forum, I have been given access to a virtual machine (VMware running WinServer2012R2). I am having multiple license manager issues that neither our IT or I can figure out how to troubleshoot and fix.

For context - I'm using LS-OPT to run optimisations with ANSYS/LS DYNA as the solver (i.e. a batch of approximately 3000 simulations using Ansys academic research dyna)

I am getting regular

  • -ANSYS License manager error System error 0 "". (See log 2020/09/30 12:39:54
  • Unexpected disconnects, Timeouts and TSL handshake errors which seem to correspond in the licdebug.DYNA_SOLVER.201.out file to the checkout of a strange feature 10017 (see 2020/09/30 12:42:46)
  • licdebug.DYNA_SOLVER.201.out screen shot:


If I run these simulations individually using the ANSYS/LS-Dyna executable through LS Run they usually run but if I queue jobs they seem to get an issue.

Any suggestions?

Comments

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    Can you update version to at least 2020 R1 by any chance ? There is a trick in recent versions that can avoid this issue.

    The VMware is where you host the licenses or run the simulations or both ?

    If you run the simulation on the same machine that hosts licenses, there is another trick that you can use.

  • Hi,

    The Ansys product is 2020 R1, and I'm told the license file is 2020 however for the Dyna solvers (DYNA_SOLVER and aa_r_dy) it always seems to check out 19.2. (Perhaps when they updated the license file it didn't include updates for LSDyna??)

    I run the simulations only on the Vmware VM, as far as I am aware the licenses are hosted on another sever (I'll confirm with IT).

    Cheers

    Nathan

  • Confirming that the license is hosted on a separate server (accessible to VM).

    The IT team administering the VM have asked the question - how does the licensing work, is it per CPU or not?

    It seems strange to me that the Dyna_solver log file shows license version 19.2 whereas the workbench ANS_WB log file shows version 20.1

    Cheers

    Nathan

  • nedwardsnedwards Member
    edited October 1

    Just creating a simple Workbench LS Dyna example using Ansys Workbench 2020 R1, I get a number of license log files which seem to contradict:

    licdebug.ANS_WB.201.out shows license revision 20.1 for ANS_WB (Shared mode)

    licdebug.MECH.201.out shows license revision 20.1 for aa_r_dy and ACT_DYNA

    licdebug.DYNA_SOLVER.201.out shows license revision 19.2 for aa_r_dy and DYNA_Solver

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    hmm, this is odd. Can you check your installation directory (default location) C:\Program Files\ANSYS Inc\Shared Files\Licensing\winx64

    and see if there is an 'update' folder here ? If so, move all the files in the update folder to replace those in 'winx64' (i.e., move up one level)

    the license is pulled according to what functionality of the software you are using. The fact that it shows 19.2 is concerning, because it means the LS-Dyna solver is using a client-side licensing binary that's from 19.2. The trick won't work with this.

  • Hi tsiriaks,

    There is no 'update' folder (presumably as this was a new VM with a clean install of Ansys 2020 R1, not an upgrade).

    IT made the comment that the license server supports both 19.2 and 20.1 (There's another VM that runs 19.2... )


    Could it have anything to do with the Dyna executable I am specifying in LS-OPT? (all three below run the simulations but the log shows use the same license)

    "C:\Program Files\ANSYS Inc\v201\ansys\bin\winx64\lsdyna_sp.exe" or

    "C:\Program Files\ANSYS Inc\v201\ansys\bin\winx64\lsdyna_sp.exe" or

    "C:\Program Files\ANSYS Inc\v201\ansys\bin\winx64\LSDYNA.exe"

    Cheers

    Nathan

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    Hi Nathan,

    For 19.2, I was talking about the trick that won't work with client-side licensing running this version, not its compatibility with license server version.

    In any case, you can try setting the following Windows environment variable

     ANSYSLI_LCP=1 

    make sure you restart all ANSYS applications after this is set (if it was running)

    Let us know if this makes a difference.

    Thanks,

    Win

  • Hi Win,

    I tried setting the Environment variable but got a completely new error message:

    "Capability LS-DYNA Solver does not exist in the ANSYS licensing pool. None of the products enabling this capability are available in the specified license path...."

    I've changed it back (and after killing through task manager the ANSYS license connect process) it appears to allow the Dyna executable to run now. However when I start a batch run I get the same strange errors that we cannot seem to troubleshoot:

    What is the 10017 it is trying unsuccessfully to checkout? (Or should I be looking somewhere else to trouble shoot this?

    Thanks

    Nathan

  • SilbaMSilbaM Member

    Hii all,

    I had installed ANSYS 16 previously, I uninstalled it and installed 2020 version.

    However, it didn't display the network specifications page (port no. etc) and directly it just started to install the products.

    & I am getting the following error message:


    Could not connect to any license server.

     The server is down or is not responsive.

        ANSYSLI_SERVERS: [email protected]

        FLEXlm Servers: [email protected]

     Your version of the ANSYS license manager software is out of date. Please download and install the current ANSYS license manager from the ANSYS Customer Portal.

     The version of the license server [email protected] [1.6.1 LM1] must be greater or equal to the client ANS_WB version [2.1.1].

  • Dear Win,

    I just checked that log file again - it appears to me that that each time it appears to try to check out aa_r_dy and DYNA_Solver to be trying to checkout one license (from the 1/4/4/25) Each of my simulations is currently set to run with 4 processors, with a current global limit set at 16 at once. Shouldn't that mean that I should be checking out 4 licenses at a time? Would this be causing the System error 0"" (with the checkout issue of 10017 in the logs above)?

    Cheers

    Nathan

  • tsiriakstsiriaks 3240 El Camino Real #290, Irvine, CA 92602Forum Coordinator

    Hi Nathan,

    Solving with 4 cores is totally fine. You only need one solver license.

    Can you try updating the ANSYS License Manager version to 2020 R2 ? This must be done on the license server machine that is hosting these aa_r_dy, among others, licenses.

    Thanks,

    Win

  • Thanks Win, I've requested IT to update license manager. I'll let you know if they do....

  • Hi Win, something I've noticed on the virtual machine is that the time keeps slipping forward (despite pointing at the same NTP time server) I wonder if this is causing issues with the license manager and forcing the drops?

  • mmadoremmadore Forum Coordinator

    @nedwards That could certainly contribute to any existing licensing issues.

  • Thanks mmadore,

    He managed to get the domain controller of the virtual machines to point at the same NTP as the license server (found it was originally pointing to the CMOS). Am having "less issues", but they are generally the same (System Error 0"" with attempt to checkout 10017) and one new one which I haven't seen before (Heartbeat) images from licdebug.DYNA_SOLVER.201.out:

    Cheers,

    Nathan


  • mmadoremmadore Forum Coordinator

    Can you try adding these to the Client and License server ansyslmd.ini files?

    ANSYSLI_FNP_IP_ENV=1

    ANSYSLI_TIMEOUT_FLEXLM=10

    ANSYSLI_FLEXLM_TIMEOUT_ENV=10000000


    Thanks

    Matt

  • Thanks Matt, I'll send a request to IT to try adding to the license server side. It may take a while as we're still in lockdown.

Sign In or Register to comment.