Error occurs while opening CFD Post Processing. ANSYS 2020 R2

Answers

  • mmadoremmadore Forum Coordinator

    @Surakshya_9 Can you try renaming your %APPDATA%\Ansys\v202 to v202.old to see if it has any impact? Please also try renaming C:\Users\<username>\.cfx to .cfx.old.


    Thank you,

    Matt

  • Surakshya_9Surakshya_9 Member
    edited October 18

    Sir, after following above step "black Screen" appers in cfd post processing. How to fix this problem?


  • mmadoremmadore Forum Coordinator

    Are you accessing this machine through a Remote Desktop connection? If so, please try setting this environment variable.

    QT_OPENGL=desktop


    If this is not through Remote Desktop, please try updating your graphics card drivers.

  • keltokelto Member

    I've tried several things to handle this issue on a local virtual machine.

    For me adding the environment variable fixed the 3D-VIewer in CFD-Pre but lead to the error "Application has terminated before command could be sent." when trying to start CFD-Post.

    Host: Fedora 33 + Gnome Boxes

    VM: Win 10 2004 + ANSYS 2020 R2

    1. Black window in 3D-viewer of CFD-Pre and CFD-Post. Added environment variable QT_OPENGL=desktop
    2. Could start CFD-Pre. Error when starting CFD-Post "Application has terminated before command could be sent." via UI. Reinstallation of Visual Studio Redistributables as mentioned in another threat doesn't seem to help.
    3. Activation of group policy as described here (on the windows vm?)
    4. Rename folders for appdata v202 and .cfx but still not able to open CFX-Post.

    Output of standalone cfdpost.exe:

    C:\>".\Program Files\ANSYS Inc\ANSYS Student\v202\CFX\bin\cfdpost.exe"
    Current working directory not writable: C:\
     -> Changing to: C:/Users/win10
    Socket error: recv: connection reset
    comm::error: GUIInterface::waitInput - Unexpected end of transmission fromAn error has occurred in cfdpost:
     
    C:\Program Files\ANSYS Inc\ANSYS
    Student\v202\CFX\bin\winnt-amd64\PostGui_ogl.exe could not be started, or
    exited with return code 255: .
     
     GUI.
    ERROR in WriteCommand: Writing command key
    ERROR in WriteCommand: Writing command key
    ERROR in WriteCommand: Writing command key
    ERROR in WriteCommand: Writing command key
    ERROR in WriteCommand: Writing command key
    ERROR in WriteCommand: Writing command key
    ERROR in WriteCommand: Writing command key
     
    C:\>Engine state was dumped to C:/Users/win10/.cfx/20.2/cfxpost/dump.cst
    


    Do you have any other ideas how to find fix this error?

  • mmadoremmadore Forum Coordinator

    What do you have for graphics card and driver for that machine? Run the command "dxdiag" and share a screenshot of the output.

  • mmadoremmadore Forum Coordinator

    @kelto . Please see below and ask your IT folks to assist.

    CFX-Pre and CFD-Post must be able to connect to an X display to be able to run even if it is running in batch mode. This is because it make use of OGL routines for a number of its features.


    One solution would be to set the DISPLAY environment variable to point to a machine on the network that is known to have a display running, eg:

    [c shell]

    setenv DISPLAY myXmachine:0

    [bash/bourne shell]

    export DISPLAY=myXmachine:0


    You may have to run the command 'xhost +' on the display machine to allow any remote hosts to connect to it.


    Alternatively if X is installed on the machine (but not running) you could run your own local version of X to connect to, eq:

    screen=10

    X :$screen

    export DISPLAY=localhost:${screen}.0


    Thanks,

    Matt

  • keltokelto Member

    I didn't really understand your answer but I've found a workaround to start CFD-Post.

    With QT_OPENGL=desktop and activated RDP I can start CFD-Post via a RDP connection without getting the error. I Just have to start CFD-Post via the RDP connection and can immediately switch back to my VM in boxes (or virtual Machine Manager)

    When CFD-Post is opened via RDP connection I can switch back to the spice/quemu connection.

    It seems to be a problem with spice/QUEMU but for me this solution is acceptable.


    Thanks @mmadore for your fast answers.

Sign In or Register to comment.