Problem with Option file and users not in it requesting research license.

So we have 5 aa_r licenses and a few other research license but this is the one giving the error. I have only 4 people setup in the options file and he was getting an error that there are no more licenses. This only happens in Ansys Mechanical APDL and not Workbench. But since there are only 4 people and 5 licenses this must be happening to others as well. Here is my option file

RESERVE 4 aa_mcad USER User1, User2, user3, user4

RESERVE 4 aa_r USER User1, User2, user3, user4

RESERVE 4 acfd_vki USER User1, User2, user3, user4

There are more lines but figured this would be good for testing.

The research licenses are also all the way at the bottom of the license file. Has anyone experienced this? Am I doing something wrong in the options file?


Regards

Sam

Best Answers

Answers

  • mmadoremmadore Forum Coordinator

    @s213bell In Mechanical APDL you are specifying which license to use, so the user needs to specify a different license than aa_r. With Workbench it will automatically look at the other licenses and use any available license that meets its need. So, for M-APDL, have them specify a different license to use when launching.


    Thanks

    Matt

  • Hello Matt,


    Oh okay that makes sense. Where do I choose which licenses? I launch the program and it just opens up. Do I choose it before running a job?


    REgards

    Sam

  • sorry should have added @mmadore

  • mmadoremmadore Forum Coordinator

    You can set this by using the Mechanical APDL Product Launcher. Once you use the Product Launcher, it will save that option as the default license.


    Thanks

    Matt

  • @mmadore So I launched that and all of them are set to teaching? The students only have access to the program and not the product launcher. What could be causing other users to have that switch. Is there a way I can set it as and administrator so all students using it on that computer automatically use those settings. ANSYS Academic Teaching Mechanical and CFD is what is selected on the lab computers that I have logged into.

  • mmadoremmadore Forum Coordinator

    The end users won't see the exact same thing as you, as they are user based settings. You can have them modify their %APPDATA%\Ansys\v202\launcher\profiles.xml to edit the lic= entry. It likely looks like "lic="aa_r"" at the moment, so they can change that to their desired license feature.


    They can run the launcher with "C:\Program Files\ANSYS Inc\v202\ANSYS\bin\winx64\launcher.exe"

  • W@mmadore what if the user doesn't have the launcher folder in appdata? I checked mine and I do and it is set correctly. Should I copy my folder into the users?


    Regards

    Sam

  • Thank you for all the help @mmadore . Just to be safe this is what i see. Seems pretty basic. so I am going to try that. If that doesn't work I will have users use the Launcher. Thank you for all your help

    <?xml version="1.0"?>


    -<profiledoc default="*** Last AE Run ***">


    <profile lastrun="1" lic="aa_t_a" simenv="AE" name="*** Last AE Run ***"/>


    </profiledoc>

Sign In or Register to comment.