Workbench Extensions Manager "Root element is missing"

The Workbench Extensions Manager is not able to initialize the Extensions. I allready tried to reinstall everything and check the license settings. What is the problem?


Best Answer

Answers

  • mmadoremmadore Forum Coordinator

    @meinhaus Open the Windows 10 control panel

    In the control panel search box, type region

    Choose the Region link, which should have appeared.

    Note down your current region type, since you might need to revert back to it if other software on your machine is dependent on your current region setting. Change to,

    Format: English

    Apply

    OK

    Make sure that the decimal system is set to dot "." not comma "," (under 'Additional Settings')


    With this setting, if ACT extensions still fail to load. Does the error messages produced change?


    If ACT still fails. The failure can also occur if the path variable has special characters or a double instance of the ; character in it.


    Does the error change if Workbench is run using the following steps?


    Start/All Program/Accessories/Command Prompt

    In the resulting command prompt run the commands


    set path=C:\Windows\System32

    cd /D "%appdata%

    move Ansys "Ansysold%time::=%"

    cd ..\Local

    move Ansys "Ansysold%time::=%"

    "C:\program files\ANSYS Inc\v194\Framework\bin\Win64\runwb2.exe"

    exit


    Does ACT extension loading still fail? Are there any changes to the error messages produced?


    Thanks,

    Matt

  • Hi Matt,

    I did both ways but it does not change and the error message still is the same.

    For your information: I'm using ANSYS 2020 R2 with Windows 10 Education.

    Do you have another idea?

    Thanks a lot!

  • meinhausmeinhaus Member
    Accepted Answer

    Hi Matt,

    I found it out. It's only working with "English(United Kingdom)" and not with only English.

    Also see here:

    Thanks.

Sign In or Register to comment.