Thin solid body in a flow field causing Fluent mesh generation problem

highhopeshighhopes Member
edited October 20 in Preprocessing

I am currently working on the simulation of flow in and around an open building and the roof has a thin section with a thickness of 0.03 meters. I use SpaceClaim to generate the geometry, and Fluent to generate the mesh. I follow the Watertight Geometry workflow and the ANSYS version is 2020 R2.

There are 2 scenarios:

  • When I want to mesh the solid region, it takes more than an hour to finish generating around 12 million cells. This is strange because this computer has meshed some other geometries much faster.
  • When I suppress the solid at SpaceClaim step and try to mesh only the fluid domain, I see a CAD import error. And the cells in and around the thin section are highlighted.

Could this all be because of the thin section? And according to SpaceClaim and Fluent Meshing, How thin is "thin"? I am not sure whether I know a way to do a tolerance-like control.

Thank you


  • Could you please share a screenshot of your thin section?

    Even if there are thin regions, you should not be seeing a CAD import error. There might be something happening with the CAD geometry. Have you checked for any errors in the geometry (using the 'Check Geometry' feature)?

    Thank you.


  • The thin section is as shown below. It is a cross section of a roof. The thinner part is 0.03-m, the thicker part is 0.3-m thick. The rest is completely fluid domain. And yes, I checked the geometry and no geometry problems were found.

    After I suppress the solid part for physics in SpaceClaim and I transfer it to Fluent Meshing, at the surface meshing step, I see the surface distribution as seen below. Here let me ask one more question. Why is the flat upper surface mesh density affected by the lower features even though now the solid part is suppressed?

    In the end, after I click on "Generate the volume mesh", I see the following. Unfortunately I cannot show you anymore the highlighted cells I mentioned in my first post because I do not know what happened basically. It just got solved by something I did. However this still took a much longer time than normal to achieve.

  • kkanadekkanade Forum Coordinator

    This is due to proximity.

    You must be using curvature and proximity sizing function to generate volume mesh.

    Due to thin region it takes good amount of time to calculate proximity sizing.

    If possible you can increase thickenss or completely ignore thickness and have zero thickness roof.



    Guidelines for Posting on Ansys Learning Forum

    How to access ANSYS help links

  • Yes, I am using Proximity sizing function but it is for other parts in the fluid domain. In the first image above, the shaded areas are solid and I am suppressing them. Therefore there are no mesh cells there which just eliminates the proximity size functioning, am I not correct?

    In the second and the third images though, we are looking the flat surface above. This surface is supposed to be now decoupled from the surface with the step-like geometry below (See the flat and the steps in the first image).

    Last but not least, I cannot increase the thickness but I had rather have a zero thickness there. I tried the zero thickness before but can you also let me know what is the key setting to make it a border between the 2 fluid parts? Only selecting the shared topology and making it a wall boundary condition in the named selections?

    Kindest regards

  • kkanadekkanade Forum Coordinator

    The size function will be computed on every facet in Fluent Meshing. So if you are importing that thin body in Fluent Meshing, it will calculate proximity sizing at those locations.

    If you do not have thin part in Fluent Meshing then you must be having some different body or part at those locations which is making proximity function to refine sizes.

    For zero thickness, you will need to use sharetopo. Please check forum posts for the same.

    Please see help manual for more details about these commands. 



    Guidelines for Posting on Ansys Learning Forum

    How to access ANSYS help links

  • Thank you for your message, but there is literally nothing above the surface you see in my 2nd and 3rd image. Moreover the shaded area in the first image does not exist in Fluent Meshing steps. Therefore my question about the density change over the surface remains. This is very important with respect to the time spent to mesh generation and solution. What do you recommend that I do? By the way I have of course no problem with this kind of density change down where there is a step in the fluid domain.

    I already looked into posts about zero thickness in the posts but its inclusion into models with extra complextiy becomes an issue especially when I have to use the combine function (In order to extract a fluid region around solid objects). Especially after using this feature, I start seeing geometry problems. If you think there is a specific part in the manuals (SpaceClaim or Fluent Meshing) I might be overlooking in the manuals, I would wholeheartedly appreciate if you pointed me in the right direction.

    Kindest regards

  • RobRob UKForum Coordinator

    Is the surface flat? Looking at the SpaceClaim image if you remove the solid the fluid still has imprinted sections.

  • kkanadekkanade Forum Coordinator

    Just with 2 images it is difficult to say why it is refining. Can you please put more images at the same place before and after mesh generation.

  • @Rob Yes, the surface is flat. Below you can see a 3D image of the edge of the roof. Here you can see only the fluid domain. Solid part was cut from it, using the combine tool. Here, I cannot see the imprints. The imprints start appearing in the meshing step, as also seen in the second image

    @kkanade The upper surface looks like the image above, and afterwards, it looks like the following

    The lower surface:

  • RobRob UKForum Coordinator

    It's the proximity function finding the adjacent surface to the edge, so it's doing what you told it to rather than what you wanted it to do! Use a local sizing to force the larger mesh on the flat surface and see how it behaves. I assume you're ignoring heat transfer as it's a void.

Sign In or Register to comment.