Maxwell 2020r1 Core Loss Issue

Hello,

I have a project set up in the 19.2 version of Ansys Maxwell with the 2D eddy current solver, and I haven't had any issues computing the core loss in this version. However, I needed to switch to the 2020r1 version of Maxwell, and for some reason the core loss always comes out as zero in this version. I've checked that the eddy effects and the core loss are enabled, and I can't find any settings that are different between the 2020 and 19.2 versions of this project.

It seems like the issue is with setting the core loss model in material properties to the "power ferrite" option. I tried calculating core loss in both project versions after setting the core loss model to "electrical steel", and the core loss was calculated accurately in the 2020 version. However, if I try to use a material with "power ferrite" type core loss, the 2020 version of Maxwell always outputs zero core loss.

Does anyone know what could be causing this? Or if there is some difference between the 2020r1 and 19.2 versions that would affect core loss calculation?

Thanks,

Anthony

Answers

  • icellb1icellb1 Forum Coordinator

    Hi, @aagosti ,

    Did you input core loss versus frequency for power ferrite? What are the automatically calculated Cm, x , y values? Could you share a screenshot of this window with your data input:

    Are the Cm, x, y exactly the same after you input core loss data in your 19.2 and 2020r1 version?

  • Hi,

    I am using values that were already calculated for Cm, X, and Y, and I've just set those values the same in the 2020 version as in the 19.2 version. The values are Cm = 1794, X = 1.1, and Y = 2.95. I believe they were originally calculated with core loss vs frequency data in the 19.2 version at some point, but I've just been using those calculated parameters and didn't input data to calculate them in the 2020 version.

    I just tried some sample core loss vs frequency data to generate those parameters in the 2020 version, and then I was able to evaluate a non-zero core loss value, so I guess that was the issue. Thanks for pointing that out, it seems like that was the one thing I hadn't checked.

    Is it typically necessary to input core loss vs frequency data and calculate Cm, X, Y even if you've already set those parameters?

    Thanks,

    Anthony

Sign In or Register to comment.