Says no licensing found.

Hello, when I try and open Mechanical APDL Launcher I am met with this window.

I have downloaded the student version, unzipped all the files, and run the steup.exe file. I have also tried deleting environment variables 'ANSYSLI_ELASTIC' and 'ANSYSLI_LCP' and still get the error. If someone could help me out I would really appreciate it!

Answers

  • mmadoremmadore Forum Coordinator

    @wgmrit What version did you install? Are you seeing errors if you try opening other products?


    Thanks

    Matt

  • Hi Matt,

    I seemed to have the same issue, do you know a way to fix this? I can open all other products just not the Mechanical APDL 2020 R2 it says no licenses found error



    Kind Regards,

    Fredy S

  • Hi Matt, I downloaded the student version from the website. When I try and open up other products most of them have a licensing issue, but some do not run into an error and open.

  • RobRob UKForum Coordinator

    Which Student version? Note, Student doesn't use the same licence system as the "licenced" versions (Teaching, Research & Commercial).

  • mmadoremmadore Forum Coordinator

    @wgmrit and @fredysabu10 This could be a permissions problem where the user is locked out of the registry. When logged in as the user, check to see if the following registry key exists:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders\AppData

    It should point to the user's APPLICATION DATA directory, C:\Users\username\AppData\Roaming


    One alternative is to log in as administrator and set the following environment variable:

    Variable: ANSYS_APPDATA_DIR

    Value: C:\Users\username\AppData\Roaming.

    You can check the appdata location by opening up a Command Prompt and typing: cd %appdata%.


    Thank you,

    Matt

  • Hi @mmadore ,

    I have the same problem.

    I tried to set that enviroment variable but it continuous not working, at least for me.

    What other thing could be? and How could I solve it?

    Thanks,

    Raul

  • mmadoremmadore Forum Coordinator

    @raulro Which version of ANSYS have you installed? Which Product?


    Thanks

    Matt

  • Matt, I tried both suggestions. I checked to see if the registry key points in the right direction and everything checks out. The second suggestion was done, I created an environmental variable named it 'ANSYS_APPDATA_DIR" and then put the value as 'C:\Users\username\AppData\Roaming' but that did not help. I was signed into administrator to do this. If this helps, I tried to run the mechanical apdl 2020 r2 as admin and it worked, but when I tried on my user account it still came up with the licensing issue.

  • @mmadore ,

    I have installed students version Ansys 2020 R2.

  • dsurendrdsurendr Irvine, CAMember

    Hello,

    Please check if your normal user account has permissions to read the files from the ANSYS Student install path.

    Normally student.lic file under C:\Program Files\ANSYS Inc\ANSYS Student\Shared Files\Licensing should be accessible to supply the licenses if you are using the Student installation package of ANSYS.

    Thank you.

  • MangeshANSYSMangeshANSYS Forum Coordinator

    can you please try starting MAPDL using command line below ? copy the line below to the clipboard

    "C:\Program Files\ANSYS Inc\v202\ansys\bin\winx64\ANSYS202.exe" -g -np 2 -lch -dir "C:\temp" -j test -s read -l en-us -t -d win32

    Click mouse on Windows start button, then type "cmd.exe" without the quotes and launch Command prompy by clicking on match for cmd.exe

    then left click in top left of the command window edit paste the copied command

    then press the enter button on keyboard to run the command

    Let us know here if it launches MAPDL for you

    if this works then you can tweak the command line to match your requirements (look up "command level" in documentation)

    I hope this helps

  • @dsurendr , I do not know what you mean by checking if my normal account has permission to read the files. I followed the file path "C:\Program Files\ANSYS Inc\ANSYS Student\Shared Files\Licensing" and the student.lic is there, but how do I know my account has permission?


    @MangeshANSYS , I copied the command "C:\Program Files\ANSYS Inc\v202\ansys\bin\winx64\ANSYS202.exe" -g -np 2 -lch -dir "C:\temp" -j test -s read -l en-us -t -d win32, into the command window and when I enter it says "the system cannot find the path specified". I also do not know what you mean by tweaking the command line to match my requirements (look up "command level" in documentation). How do I look up "command level" in documentation?

  • @MangeshANSYS I copied this command too and I had same problem as @wgmrit .

  • ChettayChettay Member
    edited December 2
  • ChettayChettay Member
    edited December 2

    I have a similar issue, it runs only as admin, any suggestions?

    For the command

    "C:\Program Files\ANSYS Inc\v202\ansys\bin\winx64\ANSYS202.exe" -g -np 2 -lch -dir "C:\temp" -j test -s read -l en-us -t -d win32

    I think you're having path issues as the path should be

    "C:\Program Files\ANSYS Inc\ANSYS Student\v202\ansys\bin\winx64\ANSYS202.exe"

    in my cmd it runs bu another error is triggered

Sign In or Register to comment.