How can I properly link Visual Studio with ANSYS Fluent, to load in UDFs

I am using Ansys 2019 R3 and Visual Studio 2017. I have always gotten the "nmake not found" error so I changed some environment variables to fix this and it kind of worked, but now I get the following error, when building libudf from Fluent (opened from Workbench):

********************************************************************************************************************************************************

** WARNING: Automatically switched to run in parallel -t1 mode. **

** Detected non-parallelized UDF usage, enabling parallel usage. **

** If you encounter any issues, please re-run with -t0 flag. **

****************************************************************************

****************************************************************************udf_names.c and user_nt.udf files in 2ddp_node are upto date.

(system "copy "D:\Program Files\ANSYS Inc\ANSYS Student\v195\fluent"\fluent19.5.0\src\udf\makefile_nt.udf "E:\Daten\Uni\Masterarbeit\Ansys\Stroemungsrohr\Stroemungsrohr_files\dp0\FFF\Fluent\libudf\win64\2ddp_node\makefile" ")

1 Datei(en) kopiert.

(chdir "E:\Daten\Uni\Masterarbeit\Ansys\Stroemungsrohr\Stroemungsrohr_files\dp0\FFF\Fluent\libudf")(chdir "win64\2ddp_node")# Generating ud_io1.h

myUDF.c

D:\Program Files\ANSYS Inc\ANSYS Student\v195\fluent\fluent19.5.0\src\main\global.h(9): fatal error C1083: Datei (Include) kann nicht ge�ffnet werden: "stdio.h": No such file or directory


I have seen that the knowledge based solution #2049257 is often recommended, but I can't access it because it is only accessible through the customer service portal.

Can somebody help me with this, please?

Answers

Sign In or Register to comment.