SpaceClaim Combine/Enclosure

koomullilkoomullil Member
edited November 27 in Preprocessing

Hi,

I am trying to get a computational domain for a simple airplane geometry. It has a rudder and two control surfaces for the horizontal stabilizer. I have this geometry as four solid bodies under one part. SpaceClaim is not able to get an “Enclosure” for the entire geometry or able to combine them to a single body.

I checked the integrity of the CAD model using the following steps.

1) Used “Check Geometry” for the part and the result was “No problem found”.

2) Used “Stitch” “Gaps”, and “Missing face” under “Repair”, and the results for all these were “No areas found”.

3) Used “Imprint” in “Prepare” and fixed all overlapping faces/edges. 

When I created “Enclosures” under “Prepare” for individual bodies, SpaceClaim created proper enclosures. However, when I tried to create an “Enclosure” for all four bodies together, I am getting an error message (see the figure Enclosure.jpg). 

I tried to combine two bodies (fuselage and one of the control surfaces), and it also gave me an error message (see the images Combine.jpg and Combine_zoom.jpg).

I also tried these operations using different options for “Share Topology” and none of them worked.   

I appreciate if you could give me any suggestions to fix this issue. I am facing the same issue with a truck geometry, which has many more bodies in the part.

Thank you.


Comments

  • peteroznewmanpeteroznewman Member
    edited November 15

    @koomullil

    I expect the cylindrical surface on the rudder and tail flaps is tangent to the cutout face in the airframe body. This is a bad situation for meshing.

    There are two directions you can go to eliminate this tangent condition.

    1) Move the cutout surface forward to create a gap with the cylindrical surfaces.

    2) Move the cutout surface backward to create an overlap between the leading edge and the cutout.

    I recommend #1 since it avoids creating elements that need a small angle at the new edges created in #2.

  • Thank you Peter. As you suggested, I used option 1 and it worked.

    Thanks again.

Sign In or Register to comment.