Topology optimization - Error messages

In the case of a topology optimization study, static input studies work but topology study does not start.

I get the following error messages:

_ LevelSet Topology Optimization solver was not able to complete its initialization step: check your input and your command files, if any.

_ The optimization solution run was terminated. Check the Optimization Output on the Solution Information object for possible causes.

My input data are 4 loads of this type:

one force and one cylindrical support

My input data for the topology study are as follows:

_ Optimization region:

_ Objective fonction: Compliance

_ Constraint fonctions: Mass and two manufacturing constraints.


If anyone has any idea of the problem, thank you in advance for your answers.

Best regards.

Philippe

Answers

  • jjdoylejjdoyle PittsburghMember

    Not sure, but I offer a few diagnostic tips:

    Are there any other *.out or *.err files saved to the solver directory that might offer clues as to what the issue is?

    I am assuming your manufacturing constraints are limited to either member size, pull out and/or am overhang. These are documented as the only supported manufacturing constraints as of R2020-R2 under Level Set Limitation doc.

    From the image you shared, the Connections Branch is not empty. Is the object under the Connections folder supported by Topo-Opt level set option?

    Can you get this to run successfully with Density Based Optimization?

    Can you get anything to run with this model (i.e. remove all manufacturing constraints, empty the connections folder and replace the cylindrical constraint with a simple fixed constraint)?

    Can you get any other test model to run?

  • Hello.

    First of all thank you for your help. Here are my answers and how I solved my issue.

    1°/ " From the image you shared, the Connections Branch is not empty. Is the object under the Connections folder supported by Topo-Opt level set option?"

    Answer: My error does indeed come from my input data. The material used in the study was configured with non-linear data (plasticity curve). But I had left in Material, Nonlinear Effects --> on. it is a mistake.

    2°/ " Can you get this to run successfully with Density Based Optimization?"

    Answer: No

    3°/ "Can you get anything to run with this model (i.e. remove all manufacturing constraints, empty the connections folder and replace the cylindrical constraint with a simple fixed constraint)?"

    Answer: Impossible to obtain results in spite of my different settings in the optimisation study. The topology calculation did not start.

    4°/ "Can you get any other test model to run?"

    Answer: I got immediate results on other studies as soon as I switched to "Nonlinear Effects" OFF.

    Best regards.

    Philippe.

Sign In or Register to comment.