Fluent to Ensight for large transient simulations

danbencedanbence Member Posts: 4

Exporting an ensight case gold file from fluent works well. However, with large simulation, the export process adds many hours onto the simulation time. I found that ticking the “EnSight Parallel” option in the fluent export window speeds up the process considerably.

However, I cant find a way to load the files into EnSight (2020.r2) without fatal errors. Fluent creates a subdirectory with as many .encas files as there are cpu cores. (cnode_0.encas , cnode_1.encas etc)

If I load the set of encas files by specifying “cnode_*.encas” as the filename, I get the following error:-

Error ERROR: Error> {s1:1} readensight_file_descrip() in geom.c:1215

of EnSight Server 2020 R2:

Error ERROR: ensight error; type=Error no= 3 (00000003)

Error ERROR: Reading geom file description line

Error ERROR:

Error reading data.

Error from dr_do_read2().

If I use the “multiple file interface” button and add to list “cnode_*.encas”. I get the same error.

As I am trying to perform a task that practically everyone else needs to do, I can only imagine there is some step I don’t know about. Should this method work ? Perhaps “ensight parallel” is not supported with moving meshes ?

Any advice would be appreciated.

Tagged:

Comments

  • Kalyan GoparajuKalyan Goparaju Posts: 236Member
    edited December 2020

    Hello,

    Within the subdirectory that Fluent creates, in addition to the .encas files, there should be other folders with names starting with CNODE_*. Each of these folders should contain the .geo file and whatever the scalar and vector files that you have asked Fluent to write out. From the error, it sounds like EnSight wasn't able to find geometry information which is inside these subdirectories indicating that the directories are missing. This could be for one of two reasons

    1. Only the cas file was loaded into fluent at the time of writing or to put it differently, there was no variable data that could have been written out.
    2. Failed write operation.

    Can you check if the fluent session contains data? If it doesn't, that explains the cause of the error. If it does, can you try writing out the parallel format again and see if the subdirectories are created?

    Thanks,

    Kalyan

  • danbencedanbence Posts: 24Member

    Thanks for your comments.

    In preparing my reply, I believe I have worked out the issue. When writing out the ensight parallel file in Fluent, I was unticking the “separate file for each timestep” box. With it unticked, ensight reports an error. Ensight might be confused by cells moving between nodes due to dynamic meshes.

     Using the “multiple file interface” and “adding to list” all the encas files in the created sub-directory, the load seems to work correctly.

  • Kalyan GoparajuKalyan Goparaju Posts: 236Member

    Hello,

    I am glad that you were able to find a solution.

    Cheers,

    Kalyan

Sign In or Register to comment.