reg_ansysedt_error

I have installed Ansys 18.0. But unable to open. I saw this forum for the solution, tried running configThisMachine got an error. How to get resolve this issue?


Comments

  • mmadoremmadore Forum Coordinator

    @Ranjitha This issue is due to a Windows Update, Microsoft update KB4571756. The solution for version 18.0 is to uninstall the Update.

     To uninstall the Windows update:

    1.           Select the start button or Windows Desktop Search and type update history and select View your Update history.

    2.           On the Settings/View update history dialog window, Select Uninstall Updates.

    3.           On the Installed Updates dialog window, find and select KB4571756, and then click the Uninstall button.

    4.           Restart your Windows device.

     

    Additionally, you may be able to run the following from an elevated CMD to uninstall the update:

       wusa /uninstall /KB:4571756 /quiet /promptrestart


    For versions 2018.0 (19.0) and newer, you may try setting the environment variable ANSYS_EM_DONOT_PRELOAD_3DDRIVER_DLL=1 to get around the problem.

     

    For guidance on creating an Environment Variable please refer to this link. You need to create a NEW Variable.

    https://www.onmsft.com/how-to/how-to-set-an-environment-variable-in-windows-10

     

    New Variable Name: ANSYS_EM_DONOT_PRELOAD_3DDRIVER_DLL

    New Variable Value: 1

     

    Thank you,

    Matt

     

  • I tried everything. But it's not happening. I followed each step and did.

  • mmadoremmadore Forum Coordinator

    @Ranjitha Can you please provide a list of all current Windows Updates installed?

    1. Open Search/Cortana.
    2. Search for 'cmd'.
    3. Open a command prompt with admin privileges. (right-click -> Run as administrator)
    4. Type systeminfo.exe and press Enter.
    5. Under the Hotfix(s) section, you can find the list of Windows updates that you have installed on your device.
    6. Please send a screenshot of the output


  • mmadoremmadore Forum Coordinator

    @Ranjitha What happens when you try to open Electronics Desktop? Do you see any error messages or does it just not do anything? Have you tried installing a newer version?


    Thanks

    Matt

  • When I try to open it. It will just load but does not open. No error. Can you send a newer version link? I mean for Electronics Desktop.

  • Thank you. I downloaded Ansys 19 version. It worked.

  • mmadoremmadore Forum Coordinator

    That's great, happy to hear it!

Sign In or Register to comment.