Maxwell 3D license run in CentOS8

Dear Ansys Technical support team,

I am HPC Research Facilitator at Palmetto supercomputer, Clemson University.

I have been supporting many users running Ansys product in our supercomputer. In our previous system, we use Oracle Linux and we have no problem running this but since we upgraded our system to CentOS8, we start having the problem. The Ansys version is 20.2 and the model is ElectroMagnetic running Maxwell 3D. At Clemson, we have 550 license to run Ansys license. 

I am unsure if the error is due to the incompatible between Ansys and our CentOS8 (see the warning below)

1. If we use only 4 cores to run, the error not related to license:

 

### Warning: CentOS {version} is newer than all currently-supported versions.

 

       Currently-supported Linux versions include:

       - Red Hat Enterprise Linux 64-bit: Versions 7

       - SUSE Linux Enterprise Server 64-bit: Versions 12 & 15

[error] Project:DOE_motor_dual_freq, Design:Maxwell3DDesign_nobnd_trg_TDM_per (Transient), Periodic Time Domain Domain Decomposition requested, but the active machine configuration does not support distributing transient solutions. -- Simulating on machine: node1904 (11:57:30 AM Dec 28, 2020)

[error] Project:DOE_motor_dual_freq, Design:Maxwell3DDesign_nobnd_trg_TDM_per (Transient), Simulation completed with execution error on server: node1904. (11:57:35 AM Dec 28, 2020)

*** Error: Unsupported version of RedHat

 

2. Using 5 cores, the error directly show the anshpc license related

 

### Warning: CentOS {version} is newer than all currently-supported versions.

 

       Currently-supported Linux versions include:

       - Red Hat Enterprise Linux 64-bit: Versions 7

       - SUSE Linux Enterprise Server 64-bit: Versions 12 & 15

*** Error: Unsupported version of RedHat

[error] Project:DOE_motor_dual_freq, Design:Maxwell3DDesign_nobnd_trg_TDM_per (Transient), Failover feature 'ANSYS HPC' specified in license preferences is not available.

Request

Tagged:

Answers

  • mmadoremmadore Forum Coordinator

    @wcao To avoid the first error, set the variable ANS_IGNOREOS=1. CentOS 8 is unsupported and other issues may arise.


    For running more than 4 cores you need to set your HPC and Analysis options as seen here, make sure to modify the 'Options for Design Type' to match the design type you are running.


  • tuevutuevu Member

    Thanks for your reply @mmadore .

    I already set ANS_IGNOREOS=1 in our batch script prior to running.

    Most of the settings are the same except the Design Type: Maxwell 3D.

    As I run everything in batch script (not via GUI), Im looking to replace that option with the command line.

    Will let you know if I still have that error

  • mmadoremmadore Forum Coordinator

    @tuevu What you will want to do is add batchoptions to your submission.

    -batchoptions " 'HPCLicenseType'='Pool' 'Maxwell 3D/UseLegacyElectronicsHPC'=1"

Sign In or Register to comment.