Ansys AIM unable to open following license error

Aidan_JAidan_J Member Posts: 13

I am running Ansys Discovery AIM on a sever based license (Formula student, 5 sponsored licenses distributed by tunnelling into central computer). The tunnelling software is PuTTY, however during a CFD simulation my internet dropped out and my connection to the licensing computer failed. This is not uncommon however this time I failed to restart the connection before the 1h grace period expired. Once this had happened, I tried to close AIM, and it became unresponsive. After a couple of hours I decided to close it forcefully via the "program is unresponsive" dialogue.

Ansys AIM now is unable to open at all, opening straight to an unresponsive page despite restarting my PC, as shown below. This screen persists indefinitely and clicking on anything brings up the same "program is unresponsive" dialogue.

Other Ansys products which rely on the same license, such as Spaceclaim still work just fine, so the licensing still works fine

opens straight to:

Anyone know what I should do here?

Tagged:

Best Answer

Answers

  • mmadoremmadore Ansys Employee Posts: 717
    Accepted Answer

    @Aidan_J Please try renaming these 2 directories by adding a .BACK to the end?

    C:\Users\USERNAME\AppData\Roaming\Ansys\v195

    C:\Users\USERNAME\AppData\Roaming\Discovery


    Thank you,

    Matt

  • Aidan_JAidan_J Member Posts: 13

    Absolutely spot on, worked first time! thankyou very much indeed,

    Aidan

  • Aidan_JAidan_J Member Posts: 13

    @mmadore Sorry to bother you again, but since trying that fix it has become apparent that the changes made have made ansys highly unstable and it is now unable to perform any tasks, all meshes, physics solutions and results renderings result in immediate failure of the task at best, and a crash resembling the initial one at worst (opening to an unresponsive page). I have even had AIM crash with no input at all, just transitioning gradually from "normal cursor" to "cursor with processing icon" to "just processing icon" to unresponsive. Below are a couple of the error messages I managed to capture before it became unresponsive:

    It should be noted that I did not have a directory at C:\Users\USERNAME\AppData\Roaming\Discovery at all, only the \Ansys\v195 one and as such i only renamed the v195 directory.

    Any thoughts as to what might have gone wrong?

    Many thanks and apologies for the inconvenience,

    Aidan

  • mmadoremmadore Ansys Employee Posts: 717

    @Aidan_J renaming the C:\Users\USERNAME\AppData\Roaming\Ansys\v195 would not cause these errors, it simply removes all previous settings applied to bring back to a "fresh" environment. You can easily undo this change by deleting the newly created C:\Users\USERNAME\AppData\Roaming\Ansys\v195 and then renaming the C:\Users\USERNAME\AppData\Roaming\Ansys\v195.BACK to v195.

    Have you attempted to install a newer version?

  • Aidan_JAidan_J Member Posts: 13

    @mmadore thanks a lot that makes sense to me!

    Currently im running Ansys Discovery AIM 2019 R3, on the website it shows that the latest release is Ansys 2021 R1 but it makes no mention of AIM within that, does the 2021 R1 verison extend to AIM as well?

  • mmadoremmadore Ansys Employee Posts: 717

    @Aidan_J For Discovery AIM, please install 2020R2.

  • Aidan_JAidan_J Member Posts: 13

    @mmadore Thanks a lot that's very helpful, do you know where this can be downloaded from? On the website I can only find download links for Ansys Discovery 2021 R1, is there a location with older versions avaliable?

  • mmadoremmadore Ansys Employee Posts: 717

    @Aidan_J Please see it under "Prior Releases"


  • Aidan_JAidan_J Member Posts: 13

    @mmadore I really do apologise for asking so many questions but I must have found a different page than that because that looks unfamiliar. I've searched around the main ansys website for a few hours but can't find it, could you give me the link to that page please?

Sign In or Register to comment.