Help with AUTODYN using SPH solver

Hi all, I am attempting to model a 3D explosion in rock using AUTODYN via the SPH solver.

My geometry has been made in Design Modeller and symmetry planes have been added via mechanical to reduce computation time.

My analysis settings have been allocated to program controlled in both Mechanical and AUTODYN.

When I begin to solve my model in AUTODYN, AUTODYN is unable to proceed past the first cycle and crashes. No further information is given as to why AUTODYN has crashed.

I have attached my model, much help is appreciated if anyone has also encountered as similar problem and workaround before!

 

 

 

Comments

  • xfengxfeng Member
    edited August 2018

    Update: When the model is not simplified for symmetry (i.e the model shows the full region of examination) I am able to run to cycle 4 before getting the following error:

    Problem terminated .... no cell controlling time step

    Additionally, when I go to the View -> Plots tab and examine material location, my model does not show up on any cycle other than cycle 0.

     This is my error log:

    Error! Problem terminated .... no cell controlling time step
    Problem terminated .... no cell controlling time step
    CYCLE: 4, Time: NaN, Timestep: NaN  controlled by Interaction, factor: 0                                                                                             
    Converting JWL to Ideal Gas, Material: ANFO
    CYCLE: 2, Time: 1.606E-02, Timestep: 8.414E-03  controlled by SPH particle: 84800, in Part: SPH                                                                                  
    CYCLE: 1, Time: 7.649E-03, Timestep: 7.649E-03  controlled by SPH particle: 689, in Part: SPH                                                                                    
    CYCLE: 0, Time: 0.000E+00, Timestep: 0.000E+00  controlled by SPH particle: 801, in Part: SPH                                                                                    
    Initializing.....Please wait
    WARNING! Global erosion settings are ignored for structured parts.
    Checking model setup.....Please wait
    Automatically saving model, results file option switched on
    Outputs set
    Loading  complete
    Loading data  70 Mbytes
    Loading data  60 Mbytes
    Loading data  50 Mbytes
    Loading data  40 Mbytes
    Loading data  30 Mbytes
    Loading data  20 Mbytes
    Loading data  10 Mbytes
    Start loading data ...... please wait
    Opening file H:ANSYSThesis_v5_jeong_filesdp0ATDATDadmodel_0.ad

  • edited August 2018

    Hi,

      Have you tried scaling the time step and delete any misbehaving SPH node:

    SPH Cutoffs

    image

    These options let you set SPH cutoffs.

    The default values are usually good if you are using the default units (mm, mg, ms). You may want to change one or more of these defaults if you are using some other set of units.

    • Limit density / Delete node

      If the density of an SPH node drops below the minimum density or above the maximum density defined by the minimum and maximum density factor chosen for the material, you have the choice of either limiting the density to the cutoff density or deleting the node. Make your choice here.

    • Minimum timestep

      Nodes that have a timestep below the minimum timestep will be deleted.

    Regards,

    Sandeep

  • xfengxfeng Member
    edited September 2018

    Hi Sandeep, I have tried limiting SPH cutoff density to no avail. 

    I have created a working model by creating geometry through the ANSYS Autodyn standalone system.

    Much appreciate your help!

Sign In or Register to comment.