Changing license preferences for HFSS running on SLURM

vataloggvatalogg Member Posts: 8

Hello everyone,


I am trying to run an HFSS simulation on Scinet (https://www.scinethpc.ca/) that runs an SLURM scheduler. The version is 2020/R2. Licenses are provided by CMC.ca. Due to a recent update they moved to the Pro, Premium, Enterprise Licenses (the old "legacy" ones are not supported). So, they recommend to:

a) Check the use PPE product licensing in the General>Desktop Configuration option

b) Use Pool as the HPC License in the "HPC and Analysis Options".


I have put these settings in the GUI (and they seem to be saved if I reopen it), but I submit the jobs through SLURM, So, I read that there should be some SBATCH options. Here is what I use:

Then, I get the error:

[info] Running "Slurm Scheduler Proxy v19.2.2018101018(srun: enabled )" job with ID "4819108". Command line: "/scinet/niagara/software/commercial/ansys/2020r2/AnsysEM20.2/Linux64/ansysedt.exe -ng -Distributed -Monitor -Machinelist list=nia0048:40 -BatchOptions /scratch/g/gelefth/vatalogg/Batch_Options.txt -BatchSolve /gpfs/fs0/scratch/g/gelefth/vatalogg/PhysicalPatch_improved_scinet.aedt".

[error] Project:PhysicalPatch_improved_scinet, Design:HFSSDesign1 (DrivenModal), Failed to enable feature using current license settings. Note that Pro, Premium, Enterprise licenses are available on your server. To use these licenses check the corresponding UI option. For more information, search for "PPE" in the help documentation. Failover feature 'HFSS solver' specified in license preferences is not available.

Request name hfss_solve does not exist in the licensing pool.

No such feature exists.

Feature:    hfss_solve

License path: [email protected]:

FlexNet Licensing error:-5,147 -- Simulating on machine: nia0048 (2:14:33 PM Feb 08, 2021)


From SciNET, they say that the node connects to the server but asks for a feature that it is not there (hfss_solve). I know I should probably somehow use anshpc, which I can see in the list of available licenses (from line 25), but I do not know how to make my script use the available license. Any help would be greatly appreciated.


Best regards,

Vasileios

Comments

  • mmadoremmadore Ansys Employee Posts: 717

    @vatalogg The issue isn't the hpc licenses but the solver license which needs to be told to use the new PPE. You can add this to the command line: -UseElectronicsPPE

    Or you can add this to the Options File.

    Desktop/Settings/ProjectOptions/UsePPELicensing=1 


    Thanks,

    Matt

  • vataloggvatalogg Member Posts: 8
    edited February 8

    Hello Matt (@mmadore),


    Thank you a lot. This solved the problem and simulations now work.


    Best regards,

    Vasilis

  • greigpgreigp Kingston, Ontario, CanadaMember Posts: 52

    Hello, Mr. Madore,

    Another part of this issue was the licence server address:

    License path: [email protected]

    This is no longer correct. Staff at SciNet (UToronto) fixed the script that pointed to the CMC Microsystems' Ansys server (Feb. 9th, 2021), replacing this older [email protected] address with the current [email protected] address.

    Adding this to thank the SciNet staff members for their help.


    Regards,

    CMC Microsystems Technical Support staff

Sign In or Register to comment.