icemcfd will not launch

rga20rga20 Member Posts: 13

Creating a new discussion as I have not had a resolution on an earlier issue. Also editing to add that we have tried this with a newer version of Ansys (2020 R1) with similar result so it appears to be system related.


I am using icemcfd with Ansys 19.3. When I launch icemcfd it is very slow to load, sometimes taking up to 3-5 minutes.

The OS is CentOS 7.

I am using environment modules to load the software. This is the environment module.

set    topdir         /home/ansys2019r3/

set    version        v195

prepend-path PATH     $topdir/$version/ansys/bin

prepend-path PATH     $topdir/$version/Framework/bin/Linux64

prepend-path LD_LIBRARY_PATH $topdir/$version/Framework/bin/Linux64/Mesa

prepend-path PATH     $topdir/shared_files/licensing/lic_admin

prepend-path PATH     $topdir/$version/home/ansys2019r3/v195/fluent/bin

setenv ANSYS182_DIR    $topdir/$version/ansys

setenv ANSYSLIC_DIR    $topdir/shared_files/licensing

prepend-path   PATH   $topdir/$version/fluent/bin

prepend-path   PATH   $topdir/$version/icemcfd/linux64_amd/bin

setenv ICE_ACN        $topdir/$version/icemcfd/linux64_amd

prepend-path   PATH   $topdir/$version/autodyn/bin

prepend-path   PATH   $topdir/$version/Framework/bin/Linux64

prepend-path   PATH   $topdir/$version/polyflow/bin

Once I type in 'icemcfd' it hangs on ICEM_ACN is "/home/ansys2019r3/v195/icemcfd/linux64_amd" and eventually after 5 minutes the software will launch.

Eventually when it does load I get this output on the command line:

LD_LIBRARY_PATH is "/home/ansys2019r3/v195/icemcfd/linux64_amd/lib

home/ansys2019r3//v195/Framework/bin/Linux64/Mesa

home/ansys2019r3/v195/icemcfd/linux64_amd/bin

home/ansys2019r3/v195/icemcfd/linux64_amd/dif/iges

home/ansys2019r3/v195/icemcfd/linux64_amd/../../Framework/bin/Linux64

home/ansys2019r3/v195/icemcfd/linux64_amd/../../tp/IntelCompiler/2017.6.256/linx64/lib/intel64".

args =

Window information: depth = 24

                   class = 4

visual depth = 32 class = 4

can't load font screen14, using variable

can't load font symbol14, using variable

can't load font symbol18, using variable

can't load font symbol24, using variable

Graphics system = OglDL

med>

I am not sure what else to troubleshoot. This is a clean installation. I also have the same issue with an existing install on another CentOS 7 machine. Same version of Ansys.

I have tried it without the environment module and I get the same result.

Thanks for any assistance.






Tagged:

Comments

  • mmadoremmadore Ansys Employee Posts: 717

    @rga20 Could you try without specifying your own LD_LIBRARY_PATH? What is the latency with the license server? Do other applications launch in this environment without issue? This could be graphics related, could you share the results of these commands?

    glxinfo -display :0 | grep -i opengl.version

    export LIBGL_DEBUG=verbose glxgears

    export LIBGL_DEBUG=verbose glxinfo

    lspci -vnn | grep VGA -A 12

    nvidia-smi

    nvidia-settings -q NvidiaDriverVersion

    nvidia-settings -q all


    Thanks,

    Matt

  • rga20rga20 Member Posts: 13

    @mmadore

    Thanks for the reply.

    Tried without specifying our own LD_LIBRARY_PATH, no change. No issues with the license server. Other applications can launch in this environment without any problems. Right now it seems to just be ICEM-CFD.

    This just seems to be domain accounts only that this is affecting as well. This Linux server is joined to a Windows AD domain. Icem-cfd opens just fine for root and also for a local account. I used 'env' to compare the environment variables between my account and a local account as a test, there is no considerable difference.

    In playing around with the icemcfd launch script, default location: /ansys_inc/v195/icemcfd/linux64_amd/bin I commented out the following lines:


    # (re)set limits for at least OSF1 and AIX41

    #if (`id | sed 's/^[^=]*=//;s/[( ].*$//'` == 0) then

       # root must not unset the limits on

       # various operating systems

    #   echo 'Hallo root.'

    #else

    #   set uname_r=`uname -r`

    #   set uname_s=`uname -s`

    #   if ( $uname_s != "Linux" && `expr $uname_r : "B.11*"` < 4) then

    #       unlimit

    #   endif

    #endif


    And this seems to have resolved the problem for my domain account and one other. One other person is still having issues however, I need to do some further troubleshooting with that person, but I do not know why that would make a difference but it has cut the time to open the program down to ~5 seconds from 5 minutes.

    This is the output for the commands suggested:


    glxinfo | grep -i opengl.version

    OpenGL version string: 2.1 Mesa 18.3.4


    lspci -vnn | grep VGA -A 12

    0a:03.0 VGA compatible controller [0300]: Matrox Electronics Systems Ltd. MGA G200eW WPCM450 [102b:0532] (rev 0a) (prog-if 00 [VGA controller])

           Subsystem: Dell Device [1028:0444]

           Flags: bus master, medium devsel, latency 64, IRQ 20, NUMA node 0

           Memory at e5800000 (32-bit, prefetchable) [size=8M]

           Memory at eeffc000 (32-bit, non-prefetchable) [size=16K]

           Memory at ee000000 (32-bit, non-prefetchable) [size=8M]

           [virtual] Expansion ROM at ee800000 [disabled] [size=64K]

           Capabilities: <access denied>

           Kernel driver in use: mgag200

           Kernel modules: mgag200

    20:00.0 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD/ATI] RD890 Northbridge only dual slot (2x8) PCI-e GFX Hydra part [1002:5a12] (rev 02)

           Subsystem: Dell Device [1028:0444]


    There is no video card in the system. Would appreciate any ideas. Thank you,

  • mmadoremmadore Ansys Employee Posts: 717
    edited February 19

    @rga20 This machine lacks a supported graphics device and is not supported for running the UI of our applications. While you may see it work, it's unsupported.

Sign In or Register to comment.