Negative Cell Volume Alternative Solution

haebihaebi Member Posts: 1

Hi Community,

I am doing a CFD analysis for my major project in Mechanical Engineering.

I am supposed to improve a water driven motor that is build like a lobe pump.

I want to simulate a 3D domain using Fluent. The first problem to deal with was the limit of mesh cells in the student version of Ansys, while providing an acceptable orthogonal quality and skewness.

After adjusting the mesh, I ended up with 400k cells and a mesh quality which Fluent is not complaining about.

I am using an UDF for defining the rotation of the rotors in dynamic mesh and applying

the k-epsilon-model. I also set remeshing and smoothing.

However, after every iteration Fluent is remeshing and the total amount of mesh cells slightly increases, until the mesh cell limit is exceeded. Then the calculation stops and Fluent ends.

In the forum I read, that this issue can not be solved.

So, to decrease the initial number of cells, I cut down the domain more and more ending up with the following mesh.

 


 


 


 

When I simulate this geometry, the mesh cell number is fluctuating too, but I hope there is enough space to not exceed the limit.

Anyway, the problem now is that the calculation ends after a few iterations with an error message: “Negative Cell Volume”

 

What I found out is that an increase in the time step size should solve this problem, but with the current setting (picture below) it even takes one eternity to calculate some results so is there maybe another reason for this problem?



 

Here is a part of the log of the console until the error occurs. Might be a useful information for somebody.




 


 

I also carried out the field variable register as Kremella recommended at: https://forum.ansys.com/discussion/comment/103967#Comment_103967


 

Would be great to know if there is a chance to solve the negative cell volume problem, without further decreasing the time step size.

Furthermore, I would like to know what causes the fluctuation of the number of mesh cells.

 

I hope somebody has an idea to face this issue.

 

Regards, Florian

 

Comments

  • KremellaKremella Posts: 2,471Admin

    Hi,

    Firstly, I like your idea of cutting down your domain further to give yourself an additional cushion.

    Regarding your negative cell volume issue - your mesh quality is still very high. The max skewness in your domain is 0.98. I'd try to reduce that further.

    Also, what are your dynamic mesh settings and which boundaries are you applying these on? Please provide the necessary screenshots.

    Thank you.

    Karthik

  • YasserSelimaYasserSelima Posts: 931Member

    I understand that having a 3D simulation is important if you are taking the casing effect into consideration. However, I can't see this. So, why don't you start by a 2D simulation that reduces the number of cells and enables you to have smaller time step?

  • haebihaebi Posts: 3Member


    Good afternoon,

    First I want to thank you for your ideas. I think I got your point @YasserSelima. I have to speak to my supervisor about this.

    However, I also tried to improve the skewness of the model, as @Kremella suggested.


    Therefor I divided the geometry into three zones like in the picture below.


    After setting the parameters for the mesh in collaboration with my supervisor, I obtained a mesh that definitly should fit the requirements.

    The statistics of this mesh are:


    FLUENT:

    I launched fluent with the following configuration.

    The Project-Tree is shown in the pictures below:

    As fluid, I am using water-liquid from the fluent database.

    DYNAMIC MESH:

    The settings were used as follows:


    The UDF for motion of the paddles was compiled with built in compiler in fluent, that was launchend with MS visual studio 2019.

    When I started the motion preview, everything looks alright.

    The code of the UDF is shown in the picture below:


    I wanted to try this model, but when I run the calculation I receive a floating point exception now.


    So this is the next problem that needs to solved.

    I hope I provided the necessary information in this comment and am looking forward to get some help for my problem(s).

    Thanks a lot for your help and time!


    Best regards, Florian

  • YasserSelimaYasserSelima Posts: 931Member

    Go to Controls and decrease the under-relaxation factors ... at least for few time steps.

    In methods, use first order whenever available.

    Decrease the time step to a very low value ... increase the number of iterations in every time step .. and decrease the residuals convergence criteria.

    Run few time steps like this until you find the residuals converge (reach straight line) ... now increase the under-relaxation and time steps.

  • haebihaebi Posts: 3Member

    Hello again,

    I want to finally update my discussion.

    First of all thanks for your help and the quick response.

    I troubleshooted the problem a lot together with my supervisor. One outcome was, that decreasing the time step size just delays the error with negative cell volume, because the motion of the paddle just starts later and so the error ocurrs on a later time step.

    The problem that causes the negative cell volume error might be the mesh within the tiny gaps in the fluid domain.

    For example between the two rotors.

    zoom to this section:

    The error could be caused because there is only one cell across the gap.

    To refine the mesh in this areas I enabled "capture proximity" in the mesh settings as shown in the picture below.

    The mesh that was obtained looked way better.

    This mesh might probably work for the simulation, but as I am using the student version, the number of elements is way too much now.

    The limit of mesh cells and the comment of @YasserSelima from above finally led to switch from 3D to 2D, because considering the fluid layer on the front side would just increase the number of elements further.


    The update is just an assumption what might solve the problem but maybe it is necessary for anyone else.

    Thanks again for the support!


    Best regards, Florian

  • YasserSelimaYasserSelima Posts: 931Member

    Thanks for the update!

    Good Luck!

Sign In or Register to comment.