Unable to start the Meshing editor - Linux (RHEL 7.5) VNC VirtualGL

db_ikdb_ik Member Posts: 2
edited February 16 in Ansys Products

Workbech shows an error message "Unable to start the Meshing editor" after installation of Ansys2021R1.

Ansys2020R1 is working okay, but Ansys2020R2 and 2021R1 show the similar error message and can not use the meshing editor. The design modeller is okay.

The attached file is the log file and bashrc - Linux RHEL 7.5.

Could you please check how to resolve this issue asap?

Many thank you,

IK

Answers

  • mmadoremmadore Posts: 1,057Ansys Employee

    @db_ik What happens if you start Workbench using "vglrun wb202" or "vglrun wb211".

    What do you have for graphics devices on the local and remote machines?

  • db_ikdb_ik Posts: 8Member

    Hi, thank you for your reply

    the command with

    $ vglrun /ansys_inc/v211/Framework/bin/Linux64/runwb2

    shows the error as unable to start the meshing editor.

    it works for Ansys 2020 R1 but after version 2020 R2 & 2021R1 show the error of unable to start the meshing editor.

    Fluent and design modeler are working find for all version, but for not the mesher.

    I attached the glxinfo, you can see the graphics option

    (it has Nvidia Quardo K2000 - installed the most updated driver from Nvidia)

    at front of the workstation desk, all version works fine however, remote access is the issue though version 2020R1 works all fine.

    Could you please have a look why the version 2020R2 and 2021R1 are not working...

    Many thank you,

  • mmadoremmadore Posts: 1,057Ansys Employee

    Can you run these commands and send the output?


    cat /etc/*release

    glxinfo -display :0 | grep -i opengl.version

    LIBGL_DEBUG=verbose glxgears

    LIBGL_DEBUG=verbose glxinfo

    lspci -vnn | grep VGA -A 12

    nvidia-smi

    nvidia-settings -q NvidiaDriverVersion

    nvidia-settings -q all

  • db_ikdb_ik Posts: 8Member

    Thank you for your help!

    please find attached files for the information


  • mmadoremmadore Posts: 1,057Ansys Employee

    @db_ik if you open a command prompt and run 'ping localhost' can you share the output?

  • db_ikdb_ik Posts: 8Member

    Thank you for your prompt message, please see below information for 'ping localhost'

    $ ping localhost

    PING localhost (127.0.0.1) 56(84) bytes of data.

    64 bytes from localhost (127.0.0.1): icmp_seq=1 ttl=64 time=0.056 ms

    64 bytes from localhost (127.0.0.1): icmp_seq=2 ttl=64 time=0.030 ms

    64 bytes from localhost (127.0.0.1): icmp_seq=3 ttl=64 time=0.019 ms

    64 bytes from localhost (127.0.0.1): icmp_seq=4 ttl=64 time=0.024 ms

    64 bytes from localhost (127.0.0.1): icmp_seq=5 ttl=64 time=0.024 ms

    ^C

    --- localhost ping statistics ---

    5 packets transmitted, 5 received, 0% packet loss, time 3999ms

    rtt min/avg/max/mdev = 0.019/0.030/0.056/0.014 ms

  • mmadoremmadore Posts: 1,057Ansys Employee

    @db_ik RH 7.5 is not supported for ANSYS 2021 R1. When you installed 2021 R1 it may have changed something in the ANSYS files that is affecting ANSYS 2020 R2. It's most likely related to the libs since it mentions "libstdc++.so.6".

    The LD_LIBRARY_PATH=/ansys_inc/v211/Framework/bin/Linux64/Mesa#export is set to 2021 R1. Can you delete this or set to the 2020 R2 and see if this resolves the problem for 2020 R2 since it is supported under this OS and, if so, you will not be able to run 2021 R1 on this machine without updating the OS. 

  • db_ikdb_ik Posts: 8Member

    Thank you for your comment, I applied as you recommanded but the version 2020R2 is also not working.

    At the physical workstation location, all versions are working okay, but remote access causes the issue.

    on another machine, fresh restarted the OS and cleared the caches by deleting ".ansys"

    it starts the mesh editor ONLY ONE TIME with following statement as

    "[Info] Server started at ws://0.0.0.0:0 (actual port 44911)"

    However, fails to start the mesh editor no the next opening mesh.

    Regards,

  • db_ikdb_ik Posts: 8Member

    It is now updated RHEL 7.5 to 7.7 remotely.

    It is using TigerVNC server, not Real VNC.

    After the update of RHEL, the design modeller and mesher can not start and error message is;

    [VGL] ERROR: Could not open display :1.0.

       Error: SERVER TO CLIENT CONNECTION ERROR: Connection to WB failed: System.ArgumentException: Invalid port number 0 upon calling CreatePortBasedURI

     at Ans.IPC.Remoting.Common.Connection.CreatePortBasedURI (System.Int32 portNumber, System.Type requestedType) [0x00023] in <46baf23f153a45738c126797ab4c5b9b>:0

     at Ans.IPC.Remoting.Server.ServerToClientConnection.InitialConnect (System.Type classToProxy) [0x00000] in <46baf23f153a45738c126797ab4c5b9b>:0

     at Ans.IPC.Remoting.Server.ServerToClientConnection.TryToConnect () [0x00000] in <46baf23f153a45738c126797ab4c5b9b>:0


    for the display, "vglrun -d:1.0 glxgears " is perfactly working and run ansys as "vglrun -d :1.0 wb211" showed above error.

  • _jeje__jeje_ Posts: 1Member

    Hello,

    I meet the same problem since yesterday afternoon. I am unable to open neither Design Modeler nor Mechanical and in both cases, I have the same message as db_ik gets.

    It should be noticed that it started to unwork during the same remote session (VM on RH7). The only thing I did is that I worked with Ansys Classic during few minutes, and maybe something went wrong (I already tried to remove the .ansys folder but with no success).

    If anybody has an idea of what to do, you are welcome


    Best regards,

  • mmadoremmadore Posts: 1,057Ansys Employee

    @_jeje_ Please share all of the same information requested in this thread from your systems.

  • db_ikdb_ik Posts: 8Member

    Ansys has not yet resolved this issue since I reported.

    I decided to reinstall the Linux system from RHEL 7.4 to CentOS 7.9, updated in Oct 2021, then it works.

    (NVIDIA and Virtural GL must be installed otherwise not working)

    Ansys version 2020R1 is not working with CentOS 8.4, only Ansys 2021R2 is only working with CentOS 8.4.

    Ansys workbench meshing still shows below message after finishing mesh under CentOS7.9, but it seems to mesh okay.

    ******************************************************************************

    *** A fatal error has occurred within AnsysWBU.exe and it must be closed...***

    ******************************************************************************

    regards,

Sign In or Register to comment.