"bad allocation" error in FDTD

alsheltonalshelton Member Posts: 1

Hello!

I'm attempting to run a parameter sweep in FDTD, and even though the individual files of the sweep have run and display results, when I attempt to load the individual files into the sweep as a whole, I receive an error reading "bad allocation" and am entirely unable to view any results in the visualize window. The simulation gives this error loading in the 75th simulation and does not save any data to the sweep on the base file.

My simulation is a model of a gold nano-antenna on top of a thin film and a glass substrate. For the sweep we vary the length of the antenna from 50 to 200nm using 75 points in the range. Each simulation is about 6.5GB of memory and the mesh is non-uniform with a max step of 1nm. A few photos are attached.

Please let me know if I can provide any more details, we have no idea how to handle this error.

Tagged:

Answers

  • kjohnsonkjohnson Ansys Employee Posts: 18

    Hello alshelton,

    I believe the issue is there isn't enough memory to load all of the of parameter sweep results. The E field results in particular require a large amount of memory, especially if you are recording at multiple frequency points. I would recommend that you test this by reducing the size of the results you're recording somehow, for example by only recording the "T" transmission results. I believe you should be able to do this without running the sweep again by removing the other results from the parameter sweep, right clicking on the sweep and selecting "Load from files".


    Please let me know if that helps.

Sign In or Register to comment.