How to fix 'Job error' when running Lumerical simulations

LitoLito Ansys Employee Posts: 4
edited February 23 in Ansys Products

Guidelines on how to fix 'Job error' related to MPI when running Lumerical simulations.

  • Right click on the status message to 'View job details'.
  • On Windows, depending on the 'Job error', it can be related to the MPI software on your computer.
  • Ensure that the MPI software you are using to run the simulation is installed on your computer.
  • Windows 'Control Panel > Programs and Feature', should show 'Microsoft MPI' and 'Intel MPI' in the list of installed software. If these are not found, install them from the Lumerical installation package.

Prior to installation. Ensure that Lumerical is not open or running in the background.

Microsoft MPI installation. Open the ‘MS-MPI’ folder inside the ‘Lumerical_Suite’ folder in the extracted Lumerical installation package. Run msmpisetup.exe. Install with default options when prompted and complete the installation.

Intel MPI installation. Open the ‘intel_mpi_runtime’ folder inside the ‘Lumerical_Suite’ folder in the extracted Lumerical installation package. Run w_mpi-rt_p_2018.4.274.exe. Extract and install with default options when prompted and complete the installation.

Run simulation with MPI. Open and run your simulation using the installed MPI as your job launching preset in the Resource advanced options in the Resource configuration.

Run jobs without MPI. If for some reason you are unable to install the MPI, and you are only running simulations on your PC, use 'Local Computer' as your job launching preset.


Sign In or Register to comment.