Ansys Learning Forum Maintenance

NOTICE: We will be performing backend maintenance of our Learning Forum from April 5 to April 12, 2021. The result will be a new infrastructure but with little impact to user experience and design. Currently the forum is accessible in read-only mode as we complete our final migration. Thank you for your patience. For urgent issues please visit HERE.


Error: "unable to locate checkpoint file" when running simple FDTD training simmulation — Ansys Learning Forum

Error: "unable to locate checkpoint file" when running simple FDTD training simmulation

lelma87lelma87 Member Posts: 3

I use recent version of Lumerical Suite on Windows. When running training simulation set up accordingly to FDTD100 tutorial video, simulation crashes at approx. 15%, with an error: "Process number 0 unable to locate checkpoint file." Can anyone point me to the solution of the problem? Log file attached.


Best Answer

Answers

  • LitoLito Ansys Employee Posts: 34

    @lelma87, Is the simulation file saved in a location that you have write access? Try to save the simulation example into your user account/Downloads or Desktop folder.

    Copy and paste the log results, we are unable to download files from ALF.

  • lelma87lelma87 Member Posts: 3

    Dear Lito, thank you for taking interest in my question. I tried various directories, I have admin privileges. Interrupted simmulation generates movie file and log file in simulation file directory. Results are always the same, as described. Log results below and prtscr of job details:

    Ansys Lumerical 2021 R1.2 FDTD Solver Version 8.25.2621 (Windows 64bit)

    expires (month/day/year): Permanent

    using config file: Ansys Licensing set with ANSYSLMD_LICENSE_FILE

    license host: [email protected]

    current time: Fri Mar 26 09:14:20 2021

    Running on host: 49244_CEZ

    host available memory (GB): 60.266922

    All processes are communicating and ready to proceed to simulation...

    Running fsp file: C:\Program Files\Lumerical\v211\bin\fdtd-engine-msmpi.exe -t 1 -remote -resume C:/Users/m.lelit/Documents/Lumerical training/training simulation 1.fsp

    This simulation has already been run, will run again.

    The program terminated due to an error:Unable to locate any file matching 'C:\Users\m.lelit\Documents\Lumerical training\training simulation 1_*_p0.fsp.ckpt'

    Error: Process number 0 unable to locate checkpoint file.


  • LitoLito Ansys Employee Posts: 34

    @lelma87, try to disable checkpoint on the simulation.

    Can you try and run the mwp.fsp file from this example? Does the issue happen to this example, mwp.fsp?

  • lelma87lelma87 Member Posts: 3

    @Lito, thank ou for this suggestion. This worked but for some reason the other way around: at first, chceckpoint option was already disabled and error occured. However, when I checked both "checkpoint during simulation" and "checkpoint at schutoff", checkpoint files were generated and simmulation completed cuccessfuly.

    mwp.fsp works fine regardless of checkpoint options - simmulation completed cuccessfuly with and without checkpoints.

  • LitoLito Ansys Employee Posts: 34
    Accepted Answer

    @lelma87, Glad to hear that this has been resolved.

Sign In or Register to comment.