How do I fix overlapping solids when meshing?

edangedang Member Posts: 1

Hello everyone!

I have imported a cubic cell structure that I have attached a picture for (picture 1). The problem is when meshing this structure I get 2 meshes for the overlapping solid parts between a unit cell. Picture 2 shows a single unit cell highlighted in this structure. Picture 3 shows 2 unit cells next to each other and circled is the issue I am trying to solve. The overlapping geometry makes 2 meshes in the same place. Is there a way to only mesh one of these solid faces without editing the geometry file?


Thank you to all those who view this. I have exhausted my options and have no idea of how to continue.

Answers

  • peteroznewmanpeteroznewman Posts: 11,378Member

    @edang

    When you make a unit of a 3D truss and are going to stack 4 copies of it along the X-axis, then you need to leave out the bars on the +X side of the unit cube because the missing bars are going to be filled by the next cube that is copied in. When the last cube in the row is copied into the 4th position in the stack and that is the last cube, you have to fill in the missing bars on the +X side of that cube.

    If you are making a 2D pattern and copying the cube in the X and Y directions then you need to leave the bars on the +Y face out on the unit cube.

    If you are making a 3D pattern, then you need to leave the bars on the +Z face of the unit cube.

Sign In or Register to comment.