Ansys Learning Forum Maintenance

NOTICE: We will be performing backend maintenance of our Learning Forum from April 5 to April 12, 2021. The result will be a new infrastructure but with little impact to user experience and design. Currently the forum is accessible in read-only mode as we complete our final migration. Thank you for your patience. For urgent issues please visit HERE.


New license does not work. — Ansys Learning Forum

New license does not work.

jhutton5jhutton5 Member Posts: 2

Our license file switched over to the our new one today and now we cannot access any Ansys products. Everything worked yesterday. I've updated the license server to 2021R1 as well as one of the client computers. Neither the 2021R1 or 2019R1 work. Both give different error messages. The older version gives this error message:

Failover feature 'ANSYS Academic Teaching Mechanical and CFD' specified in license preferences is not available. Request name aa_t_a does not exist in the licensing pool. No such feature exists. Feature: aa_t_a License path: [email protected]; FlexNet Licensing error:-5,147

2021R1 just says the server is not responding or available, but on the server it shows it accepts the request and then immediately shuts it down.

2021/04/01 14:51:32 CLIENT_ACCEPT 1/1/41/41 67052:10.101.134.122 2021/04/01 14:51:32 CACHE 1/1/41/41 21492:21492:LCP:[email protected]:winx64 67052:10.101.134.122 2021/04/01 14:51:32 CLIENT_SHUTDOWN 0/1/41/41 21492:21492:LCP:[email protected]:winx64 67052:10.101.134.122 

I've tried reloading the license file, updating the license file to take out the old license info, and restarting and nothing has changed anything.

Any help is appreciated. Thanks.

Comments

  • DavidYDavidY Irvine, CAForum Coordinator Posts: 15

    Hello,

    Can we start from scratch with the license server? Is it Windows or Linux? I recommend that you uninstall and then reinstall the latest license manager and the license manager patch as well. I am going to paste the complete uninstall instructions below. When the reinstall is done open up the License Management Center and then Add a License File. Does the license server start correctly? If everything starts then the license file should be fine. I recommend that you make sure the firewall is open between the machines. See below for the firewall video. Let me know if this doesn't work for you.


    Follow these steps on the license server machine. All commands must be run in an administrator command prompt window.

    1. Stop the ANSYS License Manager from the ANSYS License Management Center by following the steps contained in Stopping the ANSYS License Manager.
    2. Verify that the following processes are no longer running. If they are running, stop them before continuing the uninstall process.
    • ansysli_server.exe
    • ansysli_monitor.exe
    • ansyslmd.exe
    • lmgrd.exe
    1. Uninstall the ANSYS License Manager service. You must use the following command to do so:
    "C:\Program Files\ANSYS Inc\Shared Files\Licensing\winx64\ansysli_server" 
         -k uninstall
    
    1. Uninstall the ANSYS Licensing Tomcat service. You must use the following commands to do so:
    sc stop "ANSYSLicensingTomcat"
    sc delete "ANSYSLicensingTomcat"
    
    1. Delete the Shared Files subdirectory (C:\Program Files\ANSYS Inc\Shared Files by default).



  • jhutton5jhutton5 Member Posts: 2

    I tried all the steps provided and nothing has changed. I also verified both port 1055 and 2325 are both open on the server and can be reached by the client machine. I also re-installed Ansys on the client machine. The license server is started and all processes are up and running.

  • wrabanwraban Member Posts: 11

    @jhutton5 , in a separate email, you mentioned "Our license server is it-license04 and has a special character".

    There is a known issue with special characters in license server names for 2021R1 and is resolved in 2021R2.

    In the meantime, we do support “-“ in hostnames but will require one of two steps:

    1. If you have a previous version of an ANSYS client installed, you can use that versions Client ANSLIC_ADMIN Utility to change the server hostname. 

    2. If you don’t, you can manually edit the C:\Program Files\Ansys Inc\Shared Files\Licensing\ansyslmd.ini to reflect the server hostname.

    Please let us know the result. Thank you

Sign In or Register to comment.